Discussion in 'PowerPC Macs' started by APOWERBOOKUSER, Sep 11, 2006.

  1. APOWERBOOKUSER macrumors newbie

    Sep 11, 2006
    I have a G3 Pismo powerbook. I can access a new external hard drive through the USB port but I can't access any of six other ATA drives. Four of these drives used to be internal drives from my other mac powerbooks. They range in size from 4 Gig to 30 Gig. The other two drives are from external portable drives. They are Smartdisk drives with ATA drives. For some reason the portable Smartdisk drives stopped working so I put them in external ATA drive cases. This worked for awhile but then just stopped.

    I just got a new USB case and tried all six of the ATA drives in them but I could not access any of them. They don't even show up when I go to disk utilities.

    Why can't I access these drives any longer? Could all of those six drives go bad? Could all of the portable ATA cases be bad? This is a big mystery to me. The last drive I got, a Smartdisk 60 gig drive worked for awhile but then it would never show up on my desktop. After I took the 60 gig HD from the Smartdisk case and put it in a new USB case it worked for awhile but then stopped working. I also bought a Firewire case and it worked for awhile but then stopped working.

    Are there any settings or changes I could make on my Powerbook to be able to see these drives again? I have lots of data on these drives that I desperately need.

    I would appreciate ANY help from somebody!!!!!!!!!!!

Share This Page