Can't access Login Window for switching user...

Discussion in 'macOS' started by robert-a-hudson, Jun 22, 2011.

  1. robert-a-hudson macrumors regular

    Joined:
    Apr 11, 2006
    Location:
    Britain
    #1
    Can anybody help...

    When I go to "User>Login Window..." from the menu bar, my computer just hangs and never reaches the Login Window (it just sits with a bluey-background there and the rainbow wheel...). I've given it a few hours to try and get there, tried logging in and then trying to switch users without loading any other programs, I've even done a fresh install and tried again...

    Does anyone know what might be causing this problem? And, more importantly, of a solution?

    When I switch my computer on, it loads the login window without any problems... it's just when I try to go back to it to switch users that it's a problem.

    I'm running 10.4.11

    Thanks in advance.
     
  2. robert-a-hudson thread starter macrumors regular

    Joined:
    Apr 11, 2006
    Location:
    Britain
  3. johnfkitchen macrumors regular

    Joined:
    Sep 7, 2010
    #3
    Maybe your boot disk is overfull or needs a bit of repairing? And you appear to only have 1GB RAM, having more than one user logged in may be a stretch
     
  4. robert-a-hudson thread starter macrumors regular

    Joined:
    Apr 11, 2006
    Location:
    Britain
    #4

    Thanks for the reply johnfkitchen :)

    My boot disk has about 10GB free space.

    Also, it turns out I should update my signature... I now have 2GB RAM (which is the maximum capacity for my olde-worldie macbook pro) as I upgraded in the hope that it may speed things up and also had a vague thought that this may help with the login window.

    So... any further suggestions? How would I find out if my hard disk needed repairing? Is there anything I could check easily?
     
  5. robert-a-hudson thread starter macrumors regular

    Joined:
    Apr 11, 2006
    Location:
    Britain
    #5
    Further investigation has revealed that I can get Fast User Switching to work, however to do this I must:

    1) Go to Apple Logo :apple: > "Log Out User..." to completely log out of my session.

    2) Log back into my session as User.

    3) I can then get fast user switching to work by going to User > "Login Window..."

    Does anyone know why this would be happening...? And, more importantly, if there is a way to fix it...
     

Share This Page