Can't add my own artwork in itunes...help! :/

Discussion in 'Mac Apps and Mac App Store' started by ekmoonstone, Dec 21, 2008.

  1. ekmoonstone macrumors newbie

    Joined:
    Dec 21, 2008
    #1
    Some of my cds don't have any artwork with them (choir recordings, friends' recitals, etc) so I just want to add my own pictures or artwork in itunes. The images are all under 200x200, all jpeg (though I've tried other formats as well), and when I go into the "get info" part and add it to the artwork pane, it shows up. But when I click "ok", it doesn't show up with the rest of the albums (as Cover Flow or as Grid). I've tried "clear downloaded artwork" and then adding it, but that doesn't help either. What else can I do?
     
  2. miiles macrumors regular

    Joined:
    Aug 28, 2008
    Location:
    California
    #2
    What is happening is that you are only assigning album artwork for one song.

    Make sure you have the whole album selected before you right click for the info.

    To do this click once on song #1, then press and hold shift and click on the last song, release shift. All the songs in the album should be highlighted, then right click on one of the songs and select Get Info, then drag and drop the album artwork to the correct section.

    Hope that works for ya.
     
  3. ekmoonstone thread starter macrumors newbie

    Joined:
    Dec 21, 2008
    #3
    Thanks, but that didn't work either. I can change anything else (artist, album, etc) for the whole album, it's just the artwork that is being dumb. grrrr. any other ideas?
     
  4. Danibus macrumors newbie

    Joined:
    Jan 4, 2009
    #4
    This worked for me

    Go to the album in grid view and right click and get info

    You get the multiple item information, check the box next to Artwork and then paste your artwork into it by right clicking and paste.

    This is what I did and it worked for me

    Hope this helps
     
  5. Jiff Lemon macrumors member

    Joined:
    Apr 8, 2008
    #5
    Check the files aren't locked; Has happened to me on a couple of occasions.

    Find the file in finder and get info.

    Then under general , make sure the "locked" isn't ticked.
     
  6. RayRoa1 macrumors newbie

    Joined:
    Mar 19, 2010
    #6
    Try This

    Finder and choose Get Info. You should see the "Sharing and Permissions" options at the bottom. Depending on your set up you may need to click on the pad lock in the lower right corner to log in as Admin to make changes. You can also also choose Get Info on the folder containing all your bad music files, change the permissions then click the "gear" icon at the bottom and then click "Apply to enclosed items". Change the Privilege for "your username (Me)" to Read & Write
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    This thread is a year old and the OP hasn't been around since December, 2008. I doubt they'll see your response.
     
  8. onthelistbaby macrumors newbie

    Joined:
    Apr 17, 2013
    #8
    You are trying to change a WAV file...

    I'm chiming in because I just went through this and found my solution. I know it's an old post, but it comes up in internet searches so hopefully this thread can help someone else.

    The problem in my case, and very likely yours, is that I had imported the songs as WAV files. WAV files cannot store album art as metadata so when you try to add it nothing happens. I usually import in Apple Lossless and I could not for the life of me figure out why my art wouldn't load until I just happen to notice that the files were WAV. I had switched the import method for a specific task a while ago and forgot to switch it back.

    Try importing in a different format and it should work.

    Cheers!
     

Share This Page