Can't add ringtones to iTunes 10.5 and also to iPhone 4 (iOS 5)....

Discussion in 'iOS 5 and earlier' started by kazzarian, Oct 21, 2011.

  1. kazzarian macrumors newbie

    Oct 20, 2011
    I updated to iOS 5 yesterday and so was itunes updated......

    now i already had around 8-10 ringtones in my library........

    now when i try to add some ringtones to the library.....tried Drag n Drop....add file from menu......

    but nothing happens.......

    when i drag the file from desktop to does show that green + sign....but it does not add it..........

    any ideas what the problem is......
  2. dan8379 macrumors newbie

    Mar 19, 2011
    Can't say if this will work for you but I had the same problem. Go into the details of the ringtone and make sure that artist, song name, date, album name, etc is all filled out with something. Once I did that I was able to drag and drop my ringtone onto my phone and it worked. Before filling in that info it wouldn't work. (I searched and found others that this had worked for, so it wasn't just me).
  3. kazzarian thread starter macrumors newbie

    Oct 20, 2011
    but there are already other ringtones which have some of the above mentioned fields EMPTY.....still they work
  4. dan8379 macrumors newbie

    Mar 19, 2011
    I know...same with me, but it worked in my case. Give it a try and see...only takes 30 seconds to type some info in.
  5. kazzarian thread starter macrumors newbie

    Oct 20, 2011
  6. spartanrob macrumors 6502


    Aug 4, 2008
    Check the length of the ringtone. had the same issue on my daughters 4 that was upgraded to iOS5. the ringtones were 50 seconds. edited them to 29 seconds and everything was fine.
  7. BUFFBOY, Oct 21, 2011
    Last edited: Oct 21, 2011

    BUFFBOY macrumors regular

    Aug 23, 2010
    im having this issue too

    fixed. add artist name etc
  8. jman995x macrumors regular

    Sep 8, 2007
    Not sure if this will solve your problem, but here's how I got my Ringtones to sync to my iPhone 4S:

    1. Your music files have a specific format that allows iTunes to read them (usually .MP3)
    2. Your Ringtones also have to have a specific format in order for iTunes to know what to do with them (.M4R)
    3. Some of your ringtones might be in .MP3 format (or you might have clipped out a certain part of a song you like from an .MP3 file). In order for iTunes to recognize your Ringtone as a Ringtone file, it HAS to be in .M4R format. I don't know if you can just change the file type manually (i.e.: type in .M4R where .MP3 is). If so, then you can use a batch renamer program like "A Better Finder Rename" for Mac, or some other utility)).
    4. If just manually retyping the format doesn't work, then I would use a program such as WonderShare's "Video Converter Pro" which will let you convert Audio and Video files to other formats.
    5. As soon as I started the Video Converter Pro batch conversion from .MP3 to .M4R, Video Converter Pro started importing the new .M4R files into iTunes (10.5) and magically the "Ringtones" tab appeared on the left side of the iTunes window, as well as along the top with the other iTunes tabs such as Summary, Info, etc.

    After that, just go to the Ringtones tab at the top and click whichever Sync button you like ("All" or "Selected Ringtones").

    Hope this helps,

  9. Alaerian Guest


    Jan 6, 2005
    A barstool, Innis & Gunn in hand
    Windows or OSX?

    If you're on OSX, drag 'em into GarageBand and resend to iTunes as a ringtone.

    If you're on Windows ... sorry. Can't help you there.
  10. Seattleite macrumors member


    Jul 11, 2010
    Not sure why you're dragging and dropping, but when I make ringtones, I drag and drop from iTunes to my desktop, change the format to .m4r then just double click on them. That sends them to iTunes automatically, so no dragging and dropping back into iTunes is needed. This works on both Windows and OSX.
  11. JenniferD macrumors newbie

    Jan 24, 2011
    Thank You

    I was having the same problem.

    Easiest fix: double click no the link. iTunes automatically opened it & recognized it as a ringtone.

    Big thank you to whomever suggested this fix.
  12. wharris macrumors newbie

    Nov 4, 2011
    How I solved it

    I did everything like I used to. I cut the song down and then made a AAC version of it. I went into Finder and found the file and changed the a in the extension to a r. I then copied the file and the found the ringtones folder. (User-Music-iTunes-iTunes Music-Ringtones). I just pasted the file there along with my old ringtones. I then clicked on the file to play it and it played and moved the file into the ringtones tab. I havent synced my phone yet but im sure it will work for me. This was on leopard running iTunes 10.5
  13. dskow, Feb 16, 2012
    Last edited: Feb 22, 2012

    dskow macrumors newbie

    Feb 16, 2012
    No Joy with Lion, iOS5, and iPhone 4

    I'm having a similar problem in that when I double click on the .m4r file it just links back to the iTunes music file and plays that. I can't drag it into the Tones folder either: I get the green + sign but it won't add when I drop it. Oddly enough, I can't seem to delete the .m4a files in iTunes either.

    MacBook Pro Intel Core 2 Duo running Lion (10.7.2)
    iTunes 10.5.3
    iPhone 4 with iOS 5.0.1

    I checked on the Artist fields etc and filled something out for all of them and still no joy. ANy other ideas ?

    Thanks !

    Added resolution: Rebooting the machine cleared up the deleting files problem. Looking under the iTunes Music directory (as suggested above) I discovered I didn't have one. I created the directory. When I moved the file directly into the Music - iTunes - iTunes Music - Ringtones all was well.
  14. kipptastic macrumors newbie

    Apr 25, 2012

    I had the same problem.

    1) Leave the .mp3 as it is
    2) Import into iTunes (anyway you know how)
    3) Right click on the file within iTunes and select "Convert to AAC" (this creates an .m4a file)
    4) You can then simply change the file type from .m4a to .m4r (how to do this below)

    Convert file types. If your windows computer does not already show the file type of a file, go to control panel, folder options, view tab, advanced settings area, uncheck 'hide extensions for known file types'. then you just rename the file by erasing the existing file extension and typing in your chosen extension (ie: .m4a to .m4r).

  15. sum1t macrumors newbie

    May 17, 2012
    simple solution

    u have to convert the file to enable drag..for example.. the song file should be "songname.m4r" version..
  16. GMAYSIII macrumors newbie

    May 26, 2012
    Adding Ring Tones to 4S

    I just bought a 4S recently, and had trouble adding ring tones, untill I noticed that in Itunes, after clicking on the iPhone, in the right side of the screen there was a heading for tones and I had to set it up to sync ringtones and pick what types of ring tones to sync.
  17. HBinswanger macrumors newbie

    Dec 7, 2011
    Ringtone doesn't show up on iPhone 4s

    After much aggravation, I think I have the ringtone (with an .m4r extension) transferred from my Mac (Lion) to my iPhone 4s. At least it shows up under "Tones" in the Mac's iTunes under the phone's listing in the sidebar. But when on the phone I go to settings/sounds/ringtones all that shows up are the factory issued ringtones.

    I'm set for Manual sync.

    Any suggestions?
  18. Weisswriter macrumors newbie

    Feb 16, 2010
    Getting Sync to Work

    I too was going nuts because I had a ringtone file that showed up in the proper place in iTunes but it was NOT syncing and showing up on my 4S. I solved it by

    1. Selecting my iPhone from devices
    2. Going to Tones in the menu bar
    3. It was set to "Sync Tones/All tones" That was NOT working, though it would seem it should. I toggled it to "Sync tones/Selected tones" and made sure the one item I'd imported was checked then hit "Sync" on that page. Voila, it showed up at the to of my ringtone list.

    The key seems to be CHANGING that setting; if it's on "selected tones," try "all tones" and if it's "all tones," go to "selected tones" and make sure the one(s) you want ARE selected. Somehow this seems to "wake up" iTunes and get it to do the sync properly.

    Worked for me.
  19. Ausdime44 macrumors newbie

    Oct 29, 2012
    I may be late here. But, lets solve everyone's problem. Google iringer.exe. Open first link. Download. Import song. Edit ( which is easy as it gets to create a clip of a song for ringtone.. Even fade in and out) then export to iTunes ( save as the song name but add "ringtone or iphone" so you can see it easy) Once there, go to your library and drag it over your iphone tab on left and it auto syncs it as a ringtone
  20. lbaeder macrumors newbie

    Aug 12, 2014
    Importing an .m4r file with iTunes

    Hi there! I know this is late, but I've been having the same problem since I downloaded the latest version of iTunes (11.3.1). I've always been able to create ringtones using the same method that everyone has been describing: create a 30 second AAC version of the song, delete the original, rename the extension, import the m4r file. However, I had no such luck when I tried doing so today. I found a way around the new version of the application, but it's pretty lengthy. Someone might be able to find a shorter way, but this is what worked for me:

    1) Create a 30 second or less mp3 version (since there's no longer the option to create an AAC file)
    2) Show in finder
    3) Delete the mp3 from iTunes library (keep the file, do not move to trash)
    4) Open the mp3 with QuickTime Player
    5) Export the mp3 to iTunes (somehow this converts the file to an AAC version)
    6) Show in finder
    7) Delete the AAC version from iTunes (keep the file, do not move to trash)
    8) Change the file extension from .m4a to .m4r
    9) Import the .m4r file, and it should appear in the Tones section of your iTunes

    Hope this helps! :cool:
  21. cairo1234 macrumors newbie

    Aug 20, 2014
    and now, state how your phone was not working well ?

Share This Page