Can't Add UDID

Discussion in 'iOS Programming' started by oo7ml, Apr 9, 2015.

  1. oo7ml macrumors 6502

    Joined:
    Jan 20, 2010
    #1
    Hi,

    I am trying to add a UDID to an iOS App Build but i keep getting the following error message:

    [​IMG]

    I can add other UDID's fine... and i am typing the correct UDID in, as i am copying and pasting it.

    Can anyone advise? Thanks in advance.
     
  2. mjohnson1212 macrumors member

    Joined:
    Nov 15, 2007
    #2
    That doesn't look like a valid UDID.

    I would get it from iTunes and try that.
     
  3. oo7ml thread starter macrumors 6502

    Joined:
    Jan 20, 2010
    #3
    Hi, thanks for the reply.

    I did get it from iTunes :)
     
  4. impossiballs macrumors newbie

    impossiballs

    Joined:
    Apr 8, 2015
    #4
    I don't know for sure if this is a strict rule but I have just taken a look at some device ids I had for testing and they are all 40 characters long.

    Can you check if the id shown in iTunes has the same length? (the one in the picture seems to be shorter)
     
  5. oo7ml thread starter macrumors 6502

    Joined:
    Jan 20, 2010
  6. impossiballs macrumors newbie

    impossiballs

    Joined:
    Apr 8, 2015
    #6
    Hmmm here is the text from your two pictures (I hope I got it right):

    1) CCB32E167**0B79926FBEBF6C1BFE8DFC53860B4
    2) CCB32E167A60B79926FBEBF6C1BFE8DFC53860B4

    So if the first picture is what you enter in Apple Member center it would be natural to reject it because it is missing the 2 digits (A6 highlighted above in bold).

    If this is not the case then I am not sure what the reason might be. The few times I got a UDID wrong was always a bad copy-paste on my side.
     
  7. mjohnson1212 macrumors member

    Joined:
    Nov 15, 2007
    #7
    The reason I said it was not a valid UDID is because it's not 40 characters.

    I think the other poster is onto something with some missing digits.

    Good luck.
     
  8. oo7ml thread starter macrumors 6502

    Joined:
    Jan 20, 2010
    #8
    :-(

    I see where the mistake was... will try add it when i get home, thanks.
     

Share This Page