Can't add widgets to 10.5.8, have tried the usuals

Discussion in 'macOS' started by sommls, Jan 11, 2010.

  1. sommls macrumors member

    Joined:
    Sep 7, 2008
    #1
    Background: I am logged on as an admin to OS 10.5.8 on a 1.83GHz original MacBook Pro with 1.5 gig RAM.

    Recently (can't associate with an update or anything else obvious), I have found myself able to unzip new widgets and add them to the system library/widgets folder. They appear properly in the 'manage widgets' strip at the bottom of the display. But when trying to open them, each crashes the dashboard. This is somewhat frustrating because the legacy widgets (clock, calculator,etc) and some new 3d party ones (iStat, Periodic Table, Easy Envelopes) are fine. The problem isn't specific to particular new widgets, either.

    I've tried removing every offending widget from both the system and user library folders, trashed the com.apple.dashboard.plist and com.apple.dashboard.client.plist files (which rewrite themselves properly on reboot), repaired permissions, am logged in as an admin, rebooted multiple times, zapped the PRAM, and have no accounts with parental controls running.

    Any suggestions?
     
  2. sommls thread starter macrumors member

    Joined:
    Sep 7, 2008
    #2
    Anyone else ever seen this problem? Sorry to toss this up again, but it's just bugging the heck out of me not to understand something that should be so simple.

    I've additionally tried disabling and reenabling the dashboard via the commands listed below, following by restarting the dock using Terminal ("killall Dock") each time.

    defaults write com.apple.dashboard mcx-disabled -boolean YES
    defaults write com.apple.dashboard mcx-disabled -boolean NO

    Still no luck. Any ideas?

    Thanks for reading.
     
  3. sommls thread starter macrumors member

    Joined:
    Sep 7, 2008
    #3
    Problem solved by enabling the root account, logging in as root, then simply renaming my regular user account's short name.

    For anyone using the Dropbox service, this also necessitates relinking your account and files. That appears to work fairly painlessly, though.

    Should you need it, the current link for root login information and renaming is

    http://support.apple.com/kb/HT1428
     

Share This Page