can't boot any cdroms

Discussion in 'Mac Basics and Help' started by chad.doebelin, Mar 18, 2009.

  1. chad.doebelin macrumors newbie

    Joined:
    Mar 18, 2009
    #1
    Hi guys, I'm having a problem with a 333mhz G3 iMac.

    By trade I am a PC repair technician, I own and operate my own repair shop and hold a CompTIA A+ certification.

    Someone gave this mac to me, I know it's old, so don't tell me to use it as a doorstop, when I received it it was in working condition running mac os 9.2.1 I think.

    I cracked it open and installed more RAM, and added more VRAM as well because I had some old AGP ATI 3D Rage cards laying around in a box that were perfect donors.

    I loaded OSX panther on it and was trying to get the dual booting option (classic & OSX) to run for some reason I thought it would be acceptable to just drag the OS folder from the CDROM onto the root.

    After I did that, I told it to boot into classic mode. big mistake,


    now when I turn the mac on, it just displays the old macos logo (two blue guys kissing) and then a question mark and repeats forever

    I tried to boot from the CDROM by holding down the c key while booting, that does nothing.

    I tried a MacOS 8 install CD, a 9.2.1 and a panther disc. I know that they were burned properly because I have an old 300mhz mac pro that recognises the disks and even lets me boot from them.



    I was able to go into openfirmware by slamming a bunch of keys (i have a USB keyboard but it's not designed for apples so I don't have the command key) and reset the nvram and reset defaults and reset all, I also remembered seeing a button next to the CPU when I took the machine apart the first time. so I pulled it apart again and hit that button i think it said cuda on it or something.
    all of this, and still get nothing.

    so i figured that maybe the CDROM drive was bad or something -- I've got about 40 dead laptops with DVDroms in them at my shop so I grabbed a couple of those and tried them in that machine as well, and that did nothing.
    I also have a USB cdrom drive and I can't boot from that either.

    I have no idea how to zap the pram with a standard keyboard, and I don't even know if this would even help.


    Other things I've tried were, pulling out the old IDE harddrive and nuking the partitions using a windows PC, hoping that the OF would take the hint and default to booting the cd.

    What the hell am I doing wrong guys?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    It's old.

    You're not doing anything wrong, it's just not responding to what you're doing.

    First off, the Windows key on a standard keyboard corresponds to the command key on a Mac. So you should be able to zap the PRAM by holding windows+alt+P+R.

    Try holding alt (option) on boot instead. You should see a list of bootable volumes, even if said list is blank.
     
  3. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #3
    How DID you upgrade the VRAM??? How much VRAM do you have now? Why don't you reverse the hardware change?

    "The video in the original iMac G3/233 Original - Bondi (Revision A) can be upgraded from the default 2 MB to 6 MB via the VRAM expansion slot (the Revision B model shipped with 6 MB of VRAM standard). The video in all other models cannot be upgraded."
    http://www.everymac.com/systems/apple/imac/faq/imac-g3-video-processor-external-display-support.html


    To do dual boot, you need to install OS9 first before installing OSX.

    In term of external drive boot,
    PPC mac (imac g3) can boot from Firewire,
    Intel mac can boot from Firewire and Usb.

    Command = windows key I think

    No, it's not "2 blue guys kissing".

    300mhz mac pro? WTF?

    HOLD ON TO ALT KEY ON BOOT. What happens?

    Looks like you should buy the OS install disk.
     
  4. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #4
    There might be a way around it, but by default you can't just drag the System folder from the OS 9 install disk to a new drive. You can, however, install OS 9 and drag that system folder around to make a backup or Live disk (which was the greatest ever).

    After that, you booting up to OS 9 with the flashing ? is saying that the machine can't find a system folder to boot up to.

    I know when formatting a drive through OS X, there is a checkbox to state whether or not you want the OS 9 drivers installed. I don't remember if this can be done after-the-fact or if you must select it when first formatting.

    I have no idea how you updated the (for the most part) on-board video on those old iMacs. Otherwise you've done a crazy, but fairly good job in how far you've gotten on your own (random?) skill.
     
  5. chad.doebelin thread starter macrumors newbie

    Joined:
    Mar 18, 2009
    #5
    thanks for the brotips, macfriends.

    I'm going to put all the original hardware back in, and hold down the option key during bootup.
    After I posted I went back and googled more and saw the same thing, then come here and see your concurrence on that.

    about the vram, as I said, I have a box of AGP 3d rage cards from PC's they have vram chips on them. I popped that chip on there. I guess I can't really check how much of it is registering since I can't get into a working state as of yet.

    Consultant:
    those same two blue guys keep kissing, and then showing me a question mark. ;)


    thanks for the info about bootable devices with PPC on firewire only, it explains my frustration with the USB cdrom. I just so happen to have an external firewire drive, and someone on a chan pointed me toward a image of os9 harddrive for an emulator, i'll see if i can use linux and dd to write that raw disk image to the external drive and boot that way.


    once again thanks for all the replies guys, i'm pretty confident i'll be able to get this thing running now.


    EDIT:

    damnit this mac doesnt have a firewire port on it.
    holding down the ALT key on boot does nothing
    holding down the windows key on boot does nothing
    holding down control on boot does nothing..

    next thing to try will be to write out that image to the internal drive.
     

Share This Page