Can't boot from Samsung 830 SSD

Discussion in 'MacBook Pro' started by 5tavf3l, Mar 5, 2015.

  1. 5tavf3l macrumors newbie

    Joined:
    Feb 17, 2012
    #1
    I have a problem with my Samsung 830 SSD that I have used it with my 2012 MacBook Pro 13” since it was new. It has worked fine until recently when the computer suddenly froze up. I turned off the computer, but when I started it up again it would not boot and showed the “stop” sign screen. I should perhaps mention that I recently before the crash had installed a Yosemite update. I have never tried to enable TRIM on the drive.

    I was able to access the SSD via USB when I installed a old hard drive into the computer. I ran Disk Utility on the SSD and it said it couldn’t repair it, so I backed up some files and reformatted it. I then tried to install Yosemite via a bootable USB-stick with the SSD in the computer, but it threw me a error (“File system verify or repair failed”). I wiped the SSD again and tried to install Yosemite on it with it connected via USB, which worked fine. But when I installed it in the computer and booted it up it only showed the stop sign screen again. I tried again to boot it up connected visa USB, and it worked fine. I also tried to reset the SSD from a Time Machine backup, which seem to work fine, but it still won’t boot inside of the computer.


    Conclusions:
    • Nothing seems to be wrong with the mother board, hard drive connector, etc since I have no problems when I install another hard drive in the computer.
    • Nothing seems to be wrong with the SSD, since I'm able to access it via USB and read and write files to it
    • I can boot into OS X (both from a fresh install and from a Time Machine backup) from the drive when it’s connected via USB but not when it’s installed inside of the computer.

    Has anybody any clue what might be the problem?
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    Some years of the 13" have dodgy hard drive cables which throws errors similar to what you're experiencing. I'm not sure if the 2012 was affected or not.
     
  3. 5tavf3l thread starter macrumors newbie

    Joined:
    Feb 17, 2012
    #3
    Could it really be that the hard drive cable works with standard spinning hard drives but not with SSDs?

    I actually went ahead and installed the SSD, with the Time Machine backup on it, into my old 2008 MacBook - and it booted up fine.
     
  4. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #4
    Like electrical problems in a car, the intermittent ones are the worst.

    The part itself is pretty cheap and easy to switch out. ifixit.com sells it. Can't hurt to try right?
     
  5. 5tavf3l thread starter macrumors newbie

    Joined:
    Feb 17, 2012
    #5
    Yes, I'm definitely gonna try that. Thanks for the help!
     

Share This Page