Can't boot from USB (macbook mid-2007 2,16ghz)

Discussion in 'MacBook' started by cm0scm0s, Oct 16, 2014.

  1. cm0scm0s macrumors newbie

    Joined:
    Oct 13, 2014
    #1
    Hello,

    For various reasons have to put some other OS'es on my macbook 2007.
    (My optical drive is broken please dont give me alternative options i am well aware of external devices.)

    I simply want to know why my Macbook mid 2007 running Mac os X lion will not recognize my USB as a bootable device.

    What i am trying to boot:

    ChromiumOS
    Linux (20 different distro's)
    Windows 7

    With what am i trying to boot :
    USB 8 gig flash drive formatted correctly using the disk utility.

    - holding the alt/option key
    - mac linux usb loader ( and bless )
    - refit ( does load the USB drive but installing gives me " error while loading boot .efi )

    SO, before i throw this old piece of garbage out the window and buy a i7 with gtx860m and put a nice hackingtosh and octo-boot on it.

    I would like to know if you fine gentlemen could assist me in this particular predicament.

    PS: This macbook has a core2duo, which is intel based, so it should support USB booting, just sayin
     
  2. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #2
    As far as I know, the stock efi loader really only likes to boot OS X usb drives. I've installed Lion and Snow Leopard off USB on the same model with no issue. However when installing linux or Windows 7 I always had to use a DVD either internal or external since I had dual drives and no super drive myself.

    You might be able to use rEFIt or something similar (I think there's a newer version by a different name) but it allows more flexibility with USB booting. (Nevermind, missed that you tried it on the first read.)

    I'd go find it, but I'm mobile ATM.

    Alternatively, got any friends with a USB DVD drive?
    These Macs do run windows 7 pretty well.
     
  3. cm0scm0s thread starter macrumors newbie

    Joined:
    Oct 13, 2014
    #3

    Hey thanks for replying, check out my other thread if you will http://ubuntuforums.org/showthread.php?t=2248695&p=13144902#post13144902

    I have literally tried everything that works for other people but it wont for me.

    I get crazy errors that are unheard of and i have even tried to make a .img/dmg file to boot ubuntu as the ubuntu website instructed me to do and many others have successfully done before me.

    Now i don't know if they had a mid 2k7 mb, but i found another guy that had one and he quit tryin.

    i seriously hope my luck will change.
    tho i have lost all hope
     

Share This Page