Can't boot iMac (intel)

Discussion in 'macOS' started by crockett, Feb 13, 2009.

  1. crockett macrumors member

    Joined:
    Apr 20, 2008
    #1
    I have a 24 inch iMac that is a little over a year old. It is running the current OSX with all updates but today it started screwing up out of the blue and rebooted it's self.

    The first time it happened the machine kept trying to reboot several times but wouldn't fully reboot. It would then try to reboot again.

    I finally got it to boot up completely but then the machine froze up forcing me to do a hard boot via the power switch. Now it boot's to a white screen for about 30 seconds, then goes to the white screen with the Apple logo and stops.

    I tried to do a safe boot but couldn't get it to boot that way either.

    Anyone have any ideas? I'm new to apples and don't know much on trouble shooting them.
     
  2. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #2
    Troubleshooting works much like any other computer:

    1) Have you checked the system disk's integrity?

    2) Have you tested the RAM?

    3) Have you tried booting from known good media?
     
  3. crockett thread starter macrumors member

    Joined:
    Apr 20, 2008
    #3
    I can't get the machine to boot up. It just stops at the white apple screen and won't load the OS now.
     
  4. ppc750fx macrumors 65816

    Joined:
    Aug 20, 2008
    #4
    Again, have you tried the steps I mentioned?

    I realize that the machine can't boot, but all of those can be done using the restore disks and/or other external media.
     
  5. Mr. Giver '94 macrumors 68000

    Mr. Giver '94

    Joined:
    Jun 2, 2008
    Location:
    London
    #5
    Do you have an external drive connected to it? Mine was doing the same thing until I figured out the drive was having issues. I unplugged it and the machine booted as normal. Mine is 5 months old btw...
     
  6. crockett thread starter macrumors member

    Joined:
    Apr 20, 2008
    #6
    I don't have any external drives hooked up, but I just let the machine sit about a hour or so and now it booted up. I ran the disk utility and it came up ok with no errors.

    As far as testing ram is there utility I can D/L to do that?
     
  7. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #7
    You can run the hardware test by holding D with disc 1 in the drive. Run the extended test which will catch any intermittent issues. I am pretty certain that a memory test is included with the whole battery of tests.
     
  8. crockett thread starter macrumors member

    Joined:
    Apr 20, 2008
    #8
    Ok well I tried inserting disk 1 and holding the D button, but now I'm just getting the blank white/grey screen at boot and nothing happens. Is there any way to get the disk back out?
     
  9. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #9
    Restart or power on the system, holding down the trackpad button or the eject key on the keyboard. It'll kick out the disc but of course the diagnostics haven't been run.
     
  10. crockett thread starter macrumors member

    Joined:
    Apr 20, 2008
    #10
    Well it's doing nothing. I can't run the diagnostics if it won't boot. I've tried holding D on boot with and with out the disk in it. It didn't do anything, but now I can't even get it to eject the disk.

    Now that the DVD stuck in there it won't boot past the white screen at all (eject key doesn't seem to work either). The machine was working fine up until last night when it started this. I haven't added anything new or installed anything new.

    I'm starting to think it must be something hardware related. I was thinking it might have gotten too hot but that doesn't seem to be the case.
     
  11. Jack Comrie macrumors newbie

    Joined:
    Jul 22, 2008
    Location:
    Palo Alto, California
    #11
    This happened to one of my mates today actually. He done clean install of OS X and restored to a Time Machine back-up. All is fine. His problem was with the GRUB. An app had got into it and made it keep trying to boot. So If you want I would try a clean install. And hope you got a back-up.

    Good luck with it anyway. :cool:
     
  12. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #12
    1. Turn the machine off with the disc in.

    2. Hold down the D key, and don't let go of it until you see the hardware test

    3. Press power switch.


    Is that what you were doing? There's a point where it stops paying attention to key commands. To eject this disc, do the exact same procedure, but hold eject instead of D.
     

Share This Page