Can't Boot Into Windows and Can't Delete Partition

Discussion in 'Windows, Linux & Others on the Mac' started by RushRealSlow, Aug 10, 2012.

  1. RushRealSlow macrumors newbie

    Joined:
    Oct 9, 2009
    #1
    So one day my windows just pooped out on me. I could no longer boot into it at the log in, as the disc would never show up (only my mac OS option would show up). No big deal...I was just going to delete the partition and reinstall windows. HOWEVER when I go to boot camp assistant to delete my partition, it gives me these 2 options:

    Additional software designed specifically for each Mac is required to fully support Windows. This support software installs boot camp drivers that allow your apple......

    Download the Windows support software for this Mac

    I have the Mac OS X installation disc that came with my Mac or I have already downloaded the Windows support software for this Mac to a CD, DVD, or external disk.

    No matter what option I select, it gives me this error message:

    The startup disk cannot be partitioned or restored to a single partition
    Back up the disk and use Disk Utility to format it as a single Mac OS Extended (Journaled) volume. Restore your information to the disk and try using Boot Camp Assistant again. I then tried to mess around with the disc utility but I keep getting this message "Could not modify partition map"

    Please help!! I don't know much about macs (which is why I run Windows) and I am really looking to get this thing resolved.
     
  2. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #2
    In Terminal:

    Code:
    sudo gpt -r -vv show disk0
    sudo fdisk /dev/disk0
    Report the results.
     
  3. \-V-/ Suspended

    \-V-/

    Joined:
    May 3, 2012
    #3
    When this happens I usually format the Windows partition as FAT32 via Disk Utility, then re-open the Boot Camp Assistant, which then allows me to merge the partitions back together again.
     
  4. RushRealSlow, Aug 11, 2012
    Last edited: Aug 11, 2012

    RushRealSlow thread starter macrumors newbie

    Joined:
    Oct 9, 2009
    #4
    This is what I got:


    gpt show: disk0: mediasize=500107862016; sectorsize=512; blocks=976773168
    gpt show: disk0: Suspicious MBR at sector 0
    gpt show: disk0: Bad CRC in GPT table at sector 2
    start size index contents
    0 1 MBR
    1 409639
    409640 822083584 3 MBR part 175
    822493224 264152
    822757376 154015744 4 MBR part 7
    976773120 48






    This is part of the problem. When I try to do this, I get the following error message:Could not modify partition map
     
  5. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #5
    You did not include the results from both commands, just the first one. Please provide the results from 'sudo fdisk /dev/disk0' and highlight the pasted text, click on the # button in the forum toolbar so the results format correctly.

    This problem is either the result of a botched attempt to resize the Windows partition from within Windows, using a Windows utility, or you've had a bad sector develop in which case I'd become suspicious about the disk itself.

    You will ultimately need to install a copy of GPT fdisk from Sourceforge.com. Install it, then issue this command, post the results, and use the # button in the forum toolbar to correctly format the results.

    Code:
    sudo gdisk -l /dev/disk0
    NOTE: That is a lowercase L not the number one.
     

Share This Page