Can't boot my iMac without Recovery Partition or resetting PRAM/NVRAM

Discussion in 'iMac' started by Twaize, Jun 3, 2018.

  1. Twaize macrumors member

    Joined:
    May 11, 2008
    #1
    Hello everyone,
    • I've long had trouble booting my iMac, and it's leading to some very annoying issues.
    • For the past few months, if I turn on my (2013 27") iMac, I get a flashing folder with a question mark (drive not found).
    • I can get around this by starting the Internet Recovery Partition (which takes a while), and restarting from there, or by resetting NVRAM/PRAM every time I try to boot. I've tried reinstalling macOS several times, but it hasn't helped, the issue persists.
    • Setting the startup disk doesn't resolve the issue.
    • I wouldn't mind so much, except that my entire SSD gets filled by purgeable space that never gets purged, so in no time my SSD is full and the computer can't run normally anymore.
    I haven't been able to find anyone else with this same issue, but hopefully one of you out there can help me, I'd hate to see my iMac go.

    Thank you very kindly
     
  2. NajamQ macrumors member

    Joined:
    Apr 30, 2018
    #2
    When you reinstall MacOS, do you erase the drive ?
     
  3. Twaize thread starter macrumors member

    Joined:
    May 11, 2008
    #3
    Yes, I've formatted the drive before every reinstall.
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    OP:

    Try this. Just something to try.

    Get a USB flashdrive 16gb or larger.

    Boot to internet recovery. Don't run the OS installer, quit it.

    Now open Disk Utility and erase the flashdrive to "Mac OS extended with journaling enabled".

    Now quit Disk Utility and re-open the OS installer.

    But DON'T try to install on the internal drive.
    Instead, point the OS installer at the flashdrive.
    See if you can get a copy of the OS installed onto the flashdrive.

    Does it work?
    You should get to the setup screen (on the flashdrive).
    Set up the OS, create an account.

    Can you do this?
    If this works, log out and power everything down, all the way off.

    Now, press the power on button and IMMEDIATELY hold down the option key and KEEP HOLDING IT DOWN until the startup manager appears.

    Do you "see" the USB flashdrive in the startup manager's window?
    If so, click on it and hit return.

    Do you get a good boot this way?

    Try it and get back to us.
     
  5. NajamQ, Jun 3, 2018
    Last edited: Jun 3, 2018

    NajamQ macrumors member

    Joined:
    Apr 30, 2018
    #5
    Okay. High Sierra introduced APFS which replaced HFS+ (Mac OS Extended Journaled) File System for SSDs. (NOT FUSION DRIVES)

    When you upgraded to High Sierra, it autimatically converted your SSD to APFS. It's quite possible that the controller on your SSD is having problems with new file system. That would also explain too much purgable data because may be internal maintenance routine on SSD firmware is not working properly.

    Now you can try to erase the SSD using MacOS Extended Journaled and install Sierra (Not High Sierra) or if you are reinstalling High Sierra, make sure you are not selecting the APFS File System, which I doubt will work as High Sierra doesn't ask you before converting SSD to APFS so you may be confused. (There was a check box in Beta)

    Try installing Sierra with MacOS Extended Journaled File System to see if your problem is solved.

    Alternatively see if your SSD has a firmware upgrade released in last few months.
     

Share This Page