Can't boot normally, but Target Disk Mode works

Discussion in 'Mac Basics and Help' started by samh, Apr 19, 2013.

  1. samh macrumors 6502

    Oct 29, 2009
    MBP 5,3 won't boot -- can't find the drive to mount
    But I can boot from the recovery partition on tr same disk and run disk utility and find no problems (permissions and verify disk).

    And I can boot the laptop in Target Disk Mode and use it to boot my mountain lion install on another computer just fine.

  2. Fishrrman macrumors G5


    Feb 20, 2009
    "And I can boot the laptop in Target Disk Mode and use it to boot my mountain lion install on another computer just fine.

    1. Boot externally from your cloned backup.
    2. Re-initialize internal drive
    3. RE-CLONE the contents of your cloned backup _back to_ the internal
    4. Check to see if internal is now restored and bootable.
    5. If it is -- done.

    (This is the benefit of having a cloned backup copy of the internal drive, for when you get a "can't boot" situation...)
  3. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    I think the disk is not blessed, does the Volume show up when you hold the Option key at startup?
    Did you repair the disk in Recovery mode?
  4. samh thread starter macrumors 6502

    Oct 29, 2009
    This actually started a few days ago. So after using the 2-machine setup and Target Disk Mode, I rebooted my primary machine and it works fine for a while, then while running it can't read or write to harddrive, machine locks. Reboot, and now it can't mount the boot volume again. I tried your suggestion, took all day (about 320 GB) and the cycle just repeats: works for a while, then out of nowhere can't read/write harddrive, and can't reboot without putting my primary computer into Target Disk Mode and using the alternate machine to boot.

    For kicks, I even cloned the drive onto a different partition on internal drive and used that instead, ran into the same problem.

    Also tried using a blank from scratch user account, same problem cycle.


    Yes, that's the weird part. So when I am in the part of the problem "cycle" when it won't boot from internal drive, if I hold Option key I see the boot volume and the recovery volume. The boot volume won't mount and boot, though. If I boot to the recovery volume, I can run disk utility on the boot volume and it finds no problems to repair (on the drive or the individual partitions) and permissions are fine.

    Then if I reboot, sometimes it *will* boot. Sometimes it remains unbootable until I put the computer back into Target Disk Mode and use a second machine to boot.

Share This Page