Can't boot-up, don't have permission to my Hard-Drive!

Discussion in 'macOS' started by fredltd, Apr 13, 2009.

  1. fredltd macrumors newbie

    Joined:
    Apr 13, 2009
    #1
    some how i managed to completely ruin my sharing permissions on my computer.

    computer number 1 (my computer) cant access its hard drive - it had a little minus sign on the folder - when i restarted it i only get to a blue screen.

    i tried this...

    http://forums.macrumors.com/archive/index.php/t-375901.html

    and now i get a grey screen, i've tried putting the OS X disc in and it doesnt pick it up.

    the weird thing is i can access my hard drive through my other computer (computer number 2) when comp 1 is sitting on the grey screen.

    is there a way i can change some text file on the hard drive to change all the sharing permissions or something???
     
  2. windels macrumors regular

    windels

    Joined:
    Oct 12, 2008
    Location:
    Belgium
    #2
    are you sure it has something to do with permisions?

    If so , I can't help you. but once I also hung at the blue screen. the solution was to take the leopard disk, boot it and use the EHBO feature from the disc utility, maybe you coud try that?
     
  3. Cavas macrumors newbie

    Cavas

    Joined:
    Feb 8, 2009
    #3
  4. fredltd thread starter macrumors newbie

    Joined:
    Apr 13, 2009
    #4
    thats the problem, i just tried that and now i'm left with a grey screen and a mouse pointer.

    good idea though!
     
  5. SaNdMaX macrumors newbie

    Joined:
    Apr 14, 2009
    #5
    Can you run the hardware diagnostic test when it boots by pressing and holding the D key?

    If you could boot from the Install DVD, you have to go into Disk Utility and try doing a Repair Disk Permissions.
     
  6. Cavas macrumors newbie

    Cavas

    Joined:
    Feb 8, 2009
    #6
    fredltd, what do you mean by saying that you have access to your HD through computer #2 ? Is it perhaps possible to use comp. # 2 to change the permissions on comp.#1 HD?
     

Share This Page