Can't boot Windows or Windows DVD - Black screen!

Discussion in 'Windows, Linux & Others on the Mac' started by estutmirleid, Sep 15, 2013.

  1. estutmirleid macrumors newbie

    Jun 22, 2012
    I had a perfectly functional Windows 7 x64 Pro installation on my Mac mini (2011) until recently. Now when I attempt to boot it I get nothing but a black screen indefinitely. I don't recall having done anything in Windows that may have caused this; in fact, it's been some time since I booted into it. So, I'm suspecting it must be something I did whilst booted into OS X.

    I've tried booting into Safe Mode by tapping F8 after selecting Windows from the Startup Manager - no change.

    I've tried selecting the Windows install from the Startup Disk preference pane, but it doesn't actually appear there, oddly enough.

    I've tried booting from a Windows 7 x64 Pro DVD in order to perform a Startup Repair, but this also goes to a black screen indefinitely. The DVD also spins down very quickly, which suggests to me it's not attempting to load anything much (if at all) from the DVD. I've tested this Windows DVD on a different Mac and it boots fine.

    My Mac mini uses the Intel HD 3000 integrated graphics, and I don't recall this being a problem when I initially installed Windows.

    Here's the partition information for the disk with the Boot Camp partition on it:
    gpt show: disk3: mediasize=500107862016; sectorsize=512; blocks=976773168
    gpt show: disk3: Suspicious MBR at sector 0
    gpt show: disk3: Pri GPT at sector 1
    gpt show: disk3: Sec GPT at sector 976773167
          start       size  index  contents
              0          1         MBR
              1          1         Pri GPT header
              2         32         Pri GPT table
             34          6        
             40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
         409640  156303528      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
      156713168    1269536        
      157982704  659841040      3  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
      817823744     262144        
      818085888  158687232      4  GPT part - EBD0A0A2-B9E5-4433-87C0-68B6B72699C7
      976773120         15        
      976773135         32         Sec GPT table
      976773167          1         Sec GPT header
    Here's some additional info on that disk:
    Disk: /dev/disk3	geometry: 60801/255/63 [976773168 sectors]
    Signature: 0xAA55
             Starting       Ending
    #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
    1: EE    0   0   2 - 1023 254  63 [         1 -  818085887] <Unknown ID>
    *2: 07 1023 254  63 - 1023 254  63 [ 818085888 -  158687232] HPFS/QNX/AUX
    3: 00    0   0   0 -    0   0   0 [         0 -          0] unused     
    4: 00    0   0   0 -    0   0   0 [         0 -          0] unused
    From what I can tell, this means my hybrid MBR is intact.

    NB: The disk containing my Boot Camp doesn't have a bootable OS X install on it. That's actually safe, and perfectly functional, on a separate internal drive.

    I asked for help on the Apple forums but didn't get anywhere. Hopefully someone here will know more?
  2. xcodeSyn macrumors 6502a

    Nov 25, 2012
    Since the Windows partition didn't appear in the Startup Disk pane. no wonder it could not boot into Windows. There is definitely some other hardware component blocking the Windows partition/disc from booting. What are your other disks from disk0 to disk2? It's likely one of them is blocking Windows from booting. It has been well established that hardware components with Marvell chipset could stop Windows from install/boot in Mac Pros, but no idea if this applies to your case.
  3. estutmirleid thread starter macrumors newbie

    Jun 22, 2012
    I agree that this is a strong indicator that there's something wrong, but what baffles me is why I can't even boot into a functional Windows 7 DVD.
    The only other physical disk on the Mac is an SD card in the slot on the back, and this doesn't get recognised at all in the Startup Manager because it's just an HFS data drive, containing nothing bootable at all. I suppose I could remove this from the computer during boot, see if that helps, but I'm confident that this was inserted during all previous successful Windows boots prior to my current predicament.
    The other disk is a DMG that gets mounted on login, so doesn't exist during boot.
    Hmm, maybe I should just unplug everything that isn't strictly required during boot and see if a hardware conflict is causing this.
  4. estutmirleid thread starter macrumors newbie

    Jun 22, 2012
    Well, I unplugged everything except the keyboard, mouse and display, and Windows booted fine! So, thanks for the nudge in that direction.

    Tomorrow I'll figure out exactly which device is responsible.
  5. estutmirleid thread starter macrumors newbie

    Jun 22, 2012
    *SOLVED* Can't boot Windows or Windows DVD - Black screen!

    Turns out the culprit is my Plextor PX-120U USB BDROM drive. I unplugged it and Windows now boots fine.

    Just in case anyone else encounters the same problem…

Share This Page