Can't buy or update ANYTHING on Mac App Store in El Capitan

Discussion in 'Mac Apps and Mac App Store' started by logicstudiouser, Nov 15, 2015.

  1. logicstudiouser macrumors 6502

    logicstudiouser

    Joined:
    Feb 4, 2010
    #1
    I cannot update or purchase any new apps.
    Each time I try, I get a message that says:
    '...failed to download
    Use the Purchases page to try again.'

    I get this message regardless of if I am updating or purchasing an app.
    I am STILL able to download and upgrade apple security updates, so my operating system is up to date. It is just third party applications that are the issue.

    I have done everything I can think of to fix the issue:
    1. Sign out
    2. Reset app store application (by enabling debug menu using terminal command)
    3. Remove cache (the com.appstore file)
    4. Remove any partial download files in /Library/Updates/ folder
    5. Verify & Repair disk permissions in Disk Utility
    6. Restart computer
    7. PRAM reset
    8. SMC reset
    9. In security settings in system preferences, changed 'allow apps downloaded...' from 'anywhere' to 'mac app store and identified developers'


    If anyone has any tips that could fix this, I would greatly appreciate it.
    Thanks!

    Also note: This issue for me started in Yosemite, but has never been fixed.
    I don't have this issue on my mountain lion partition.
     
  2. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #2
    Have you tried creating a new admin user to test if the problem occurs only on current user account?
     
  3. logicstudiouser thread starter macrumors 6502

    logicstudiouser

    Joined:
    Feb 4, 2010
    #3
    That seems to have fixed it for me. Thanks! HA, did everything except the most obvious troubleshooting step! lol
    Seems it was isolated to the admin account I was using. Now have to transfer everything over to the new user, oh well, at least it is fixed.
     
  4. Ebenezum macrumors 6502a

    Joined:
    Mar 31, 2015
    #4
    Glad to help.

    Moving everything to another account is lot of work, I'm not sure but I suspect that because problem is isolated to one account you might be able to fix it by removing App Store files from Preferences folder and App Store from Containers folder.

    Make sure you have a backup before trying it, just in case if it doesn't work.
     

Share This Page