Cant change Date System Pref not responding

Discussion in 'iMac' started by urbankaos, Nov 8, 2013.

  1. urbankaos, Nov 8, 2013
    Last edited: Nov 8, 2013

    urbankaos macrumors newbie

    Joined:
    Sep 7, 2011
    #1
    I've had Maverick since it was released with no problems,
    accidentally changed the date earlier from 2013 to 1993, obviously couldn't access many programs as they need the proper date to work, but when I went back onto the Date and Time to change it back and lock it... System Preference came up with 'loading date and time' on the top, and the application was not responding so I had to force quit... I tried restarting, tried it in safe mode on both my account and guest account, I've gone into Library and deleted various system pref files which I read from another similar thread, still doesn't work, I went into Disk Utilities and repaired the disk and repaired the disk permissions, I've viewed hidden files to make sure there wasn't any applications with 0 infront as I seen in another thread that it could be a problem, while looking through PreferencePanes I found the Date and Time Pane which opens but im not able to actually change the date or time and 'set automatically' is faded, and now I've noticed there is another 'date and time' icon in the System Preferences (with the actual System Pref Icon image).... this is annoying as I cant get on any brower, I cant go into the App Store, I cant get on anything as most things need the proper date to work. When I click on System Preferences myself.. some Icons work like the Desktop/Screensaver, General, Languages, Bluetooth etc.... but Date and Time wont work, just says loading all the time, Printers and Scanners just says loading aswell, but obviously its the DATE I need changed but it just isn't letting me and im not sure what else to do.. any help would be appreciated as this is my work computer and haven't been able to do any today so its really important I get this computer back up and sorted and im trying not to do a full restore as I have years of work on it, again, any suggestions would be appreciated and its driving me insane!

    Update:
    I also went onto Utilities and Console and there are 4000 messages, mostly 'error parsing stored record', other 2 being 'syncdefaultsd: NSURLconnect/CFURLConnection HTTP load failed......' and '**** globally delayed apps from syncing, next sync.......' just over and over and over again, not sure if this is anything to do with it though? and I've managed to get onto Safari (Google Chrome wouldn't let me on) and I've gone onto the Apple Website and clicked upgrade now for Mavericks to try and reinstall it but it takes me to the App Store, which aint working due to this whole date/system pref issue!

    DONE IT!!!
    went into Terminal, used the sudo date command..
    sudo date 110816472013
    and it worked :) date and time is now correct, App Store is working, and System Preferences is now working!
     
  2. alksion macrumors 68000

    alksion

    Joined:
    Sep 10, 2010
    Location:
    Los Angeles County
    #2
    You should mark your thread as resolved. It may help others searching the exact same topic ;)
     
  3. Nomtchairs macrumors newbie

    Joined:
    Feb 5, 2014
    #3
    How to use terminal and sudo date command

    Urbankaos posted:
    "went into Terminal, used the sudo date command..
    sudo date 110816472013 and it worked"

    Can someone please walk me through steps to do this?

    My computer currently will not open date & time preferences.
     
  4. Nomtchairs macrumors newbie

    Joined:
    Feb 5, 2014
    #4
    Found help in this document
    http://www.apple.com/server/docs/Command_Line.pdf
     
  5. bobsblackwell, Apr 22, 2014
    Last edited: Apr 22, 2014

    bobsblackwell macrumors newbie

    Joined:
    Apr 22, 2014
    Location:
    Here
    #5
    System Pref not working - can't access it to change date.... Need help?!

    THIS IS FOR MAC Newbies... a step-by-step instruction in simple terms. :)


    Problem?

    MAC Book Pro - Maverick 10.9.2... Tried (daftly) to find out what day of the week today was back in 1997. Went to System Preferences> Date and Time... changed it. Saved it. Et voila, sod all was now working on my Mac... I have since learned that the date I set it to back in 1997 was before the Mac thinks he was created, he can therefore nolonger operate as, back then, he was only a twinkle in the imagination of the big great Apple in the Sky.

    Result: No wifi connections, no Mac Apple support access, apps not working, general slow and slugglish 'thinking' by pooter and nowt happening but panic and stress!! Same for you right now? Read on!

    Here is the solution - may look complex but will take you just 2 mins!

    ....

    * You will need your User Account or Admin Password if there is one set on your Mac - if no password is set, happy days! *

    1. Close every app etc you don't need open.
    2. Go to the Spotlight search bar or the Finder window and find "Terminal".
    3. Open it!
    For those that haven't used Terminal before, this is basically just a mini-window that will open allowing you to type in commands to your computer's brain directly, without all the hoohah of lovely little icon artwork double-clicking etc.
    4. You will see a random string of text along the line of this...

    Last login: Sat Apr 10 18:08:20 on ttys000
    bobsblackwells-MacBook-Pro:~ bobs$


    ... but yours will have your MacBook name in (not mine!) ;)

    Type this sudo date and follow it with the numbers in the following format... . mm/dd/time/yyyy... for example, I wanted to change the time to today/now - 18:14hrs on 22nd April 2014, which is formatted as 042218142014:

    Last login: Sat Apr 10 18:08:20 on ttys000
    bobsblackwells-MacBook-Pro:~ bobs$
    sudo date 042218142014

    5. Click <enter/return> button.
    6. If you have a system password, you will now be prompted for this. Word of warning... The system works (as you have seen!) from dates. So please don't go picking a random date incase you lose any files or important updates to your software. Just pick TODAY's date - whatever date it is you are reading this - and a time maybe just ten mins or so before the actual time. That should keep everything safe for you :)

    Here's the text you will now see on your terminal...

    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.

    Password: <type in your correct password and presss enter>

    Tue 22 Apr 2014 18:14:00 BST
    bobsblackwells-MacBook-Pro:~ bobs$


    See how the date is now changed to the date I wanted? Great! I can now go back into System Preferences the standard way (click the Apple logo on top left bar of main screen or go through Finder / Spotlight if you prefer! WOOHOO! Done!! :)

    You can then close your terminal and carry on doing what you like again... I recommend having a brew and a ciggy and being chuffed with yourself in smugness for atleast 5 mins?!

    Good luck all! :)
     
  6. adrianbole macrumors newbie

    adrianbole

    Joined:
    May 20, 2016
    #6
    Thank you so much. This solved my problem.
    I just used the date format string in this thread which is obviously a way back now. I then rebooted, Date & Time preferences now opened, and I set it to auto-update from the Apple time service, and then gave it a final reboot for good measure.

    Note: Don't run iTunes, App Store or browse to HTTPS web sites before getting your clock back to the correct date/time. Incorrect time messes with the validation of digital certificates used to secure all those services. You'll get weird connection messages. Just ignore them until you your clock is back to accurate.
     
  7. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #7
    Posting to an older thread, but...

    I just encountered something not seen before on my 2010 MacBook Pro.

    I booted, and got the alert that the data wasn't set correctiy, and it wasn't -- it showed the year 2000.

    I went to the date & time pref pane and noticed the checkbox "set date and time automatically" was UNchecked. So I put a checkmark into it, closed system prefs, and rebooted.

    This STILL did not correct the date & time. Still year 2000.

    So, I wondered if the D&T pref pane had a preferences file associated with it.
    I looked in both my own [home] library and the root "Library" folder, couldn't find anything that on its face is a pref file associated with the date and time settings.

    I booted to my other OS partition (on the same MacBook), and it showed the proper date and time.
    So this seemed to indicate that the computer -could- get the proper D&T from the net. Something in the other partition's copy of the OS wasn't working as it should.

    After this, I booted back to my "main" partition, and low and behold, D&T was working properly once more. Not sure why.

    The problem was solved, but only by booting to a different copy of the OS and booting back again. (or so it seemed)

    So... my question is:
    Is there a terminal command that can be used to "re-set" the date and time preferences, to "clear them out", so to speak?

    There is a command posted above, that can be used to "force-set" the D&T to te value the user specifies.
    But how to "clear out" the old setting, and force the OS to "go to the net" again for the proper value automatically....?
     
  8. adrianbole macrumors newbie

    adrianbole

    Joined:
    May 20, 2016
    #8
    Hi Fishrrman,
    I don't know the answer to that specific question. My memory is fading, but with my problem in May, it was just stuck on automatic. After resetting the date manually through terminal and rebooting, I could then go back into preferences, set it to automatic again, reboot again, and it worked properly. Very weird.
     

Share This Page