Can't change default "Open With"

Discussion in 'macOS' started by Daniel75, Oct 2, 2008.

  1. Daniel75 macrumors member

    May 5, 2007

    VLC is opening all my flac files. I want to change it to FLUKE. Any ideas how? Obviously I did try all the usual ways - right click etc, always open with... nothing is working. I tried right click/properties/change all - defaults to VLC. It is driving me mad:) Help!

    Thank you

  2. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    Check VLC's preferences. It might be one of those applications that tries to maintain its file associations unless you explicitly tell it not to for certain file types.
  3. tkermit macrumors 68040


    Feb 20, 2004
    I'd give "onyx" a try and use it to rebuild your "launch services".

    Attached Files:

    • onyx.jpg
      File size:
      39.6 KB
  4. sOwL macrumors 6502


    Sep 25, 2007
    Nerd Cave
    have you tried opening the .flac file's "get info" menu and changing the "open with" tab with FLUKE? You'll just have to click "Change All..." after that and it will work. i guess....

    EDIT: pointless post of mine, i didnt completelly understand what you said. you've actually tried what i said. strange then..
  5. tomoliveri macrumors newbie

    Jan 11, 2009
    I'm facing the same problem, onyx didnt work.

    and when you go to 'get info' and select the default application to and hit change all it changes straight back to

    when you right click the file, open with... , other
    select and hit 'always open with' it only works on that single file.

    i had a look around vlc preferences and i cant find any settings referring to opening any extensions automatically..

    any more ideas?
  6. motulist macrumors 601


    Dec 2, 2003
    Maybe you don't have enough permission privileges on the file you're using o try to change the association. Try to use a file that was created locally, not copied over from a network, because that can sometimes limit your privilege level for that file. Also do a Get Info on the file and check what the privileges are set to. And also this might be one of those rare cases when repairing your system permissions might actually solve the problem. So try both of those and report back if either of those solved the problem.


    I see this is an old thread revived, good on you for searching tomoliveri. Try what I suggested and report back.
  7. tomoliveri macrumors newbie

    Jan 11, 2009
    sadly no luck, i ran the permissions repair first and then created a flac file, i had to download a program called max to do that and now all my flac files open with

    also yeah, its always easier when people can read back and see what's been tried.
    i was actually surprised to find someone else out there with the exact same issue.
  8. rsotres macrumors newbie

    Mar 27, 2009
    Mexico City

    I had the same problem with *.pdb files (kept associated to I tried most thing I saw in the forums, until I found o comment from an expert who mentioned how associations to an application are updated when you change the application form place.
    So I moved mercury to a different folder (in fact to the applications folder, cause it was in a subfolder). That made a copy of the application. Then I erased the old application folder (for this you need administrative privileges). And "voi-là", you can now use the get info window to change the file association without problem.
    Hope this helps
  9. Cheetah macrumors newbie

    Aug 13, 2003
    I have a similar problem.

    When I go to Get Info > Open With (and select Fluke), the file will be opened with Fluke.

    However, I go one step further and press "Change All...", The "Open with:" will go blank.

    What is the way to get around this problem?

  10. nightfly13 macrumors 6502a


    Jul 17, 2008
    Ranchi, India
    I have a similar problem. I want all .doc (and .docx) to open in Pages, rather than (slow, icky) Word. When I 'get info' on a .doc I can change it - but the 'change all' button gets ghosted out.

    I do have full read/write permission, but they have been created on a Windows box.

    Input appreciated!

    I'm considering removing Office, although that seems slightly extreme.
  11. motulist macrumors 601


    Dec 2, 2003
    Just a random stab at the problem, try making sure all the apps in question first, or just do a restart first to be sure all is closed. If you still can't do it then maybe there's something weird with the files you're trying to change the info on. So try taking a random file that you know you can change the 'open with' setting of, then rename that file so it has the extension type you want to change, and then try to do an 'always open with' get info on that file.
  12. beyondthenet macrumors newbie

    Jan 19, 2010
    trick solution

    I found a trick.

    Temporarily change the name of the App that you don't want your file to open to. Then click on your doc again. This fixed my problem.

    Afterwards I changed the name back to what it was before. Problem did not return.

    Hope this trick works for others.
  13. MacCobra macrumors newbie

    May 16, 2010
    having the same problem. the resolution is to change where is the persistant current default program ( eg: VLC to a different place even away from your application folder. then assign the app you want. You can then get the persistant program back to its place. that solve the problem, from my side.
  14. iRaV, Sep 9, 2011
    Last edited: Sep 9, 2011

    iRaV macrumors newbie

    Sep 9, 2011
    Changing Name of App Worked for me

    Worked perfectly!

    I changed to Then I double-clicked .doc, .docx, .xls, and .xlsx files in succession. All opened in pages/numbers; and the right click menu now shows the appropriate iWork program as default. [on an MBP using Lion]

  15. acjohnson55 macrumors newbie

    Oct 12, 2010
    That's so weird. I wonder what the try cause of the problem is.
  16. aninab macrumors newbie

    Apr 2, 2013
    Changing app name worked!

    I was having the same problem: tried to switch from Open Office back to MS Word, and the "change all" and "open with" commands simply didn't stick. The files still opened in Open Office as the default. I changed the name of the Open Office application, and voila! Problem fixed. :D
  17. bobwmunich macrumors newbie

    Jun 8, 2013
    Can't change default app for .odt doc

    This problem is also driving me bats. I received an .odt document and wanted to edit it OpenOffice writer. I can open it with Oo if I do it explicitly, but double clicking opens it in TextEdit.

    I tried to change the 'Open With' option in the Info Panel, but it won't replace TextEdit (I am an administrator and everything is unlocked). The trick with changing TextEdit's name doesn't work either, as it is grayed out in it's Info window.

    I am using Mac OS X 10.8.3.

    Any ideas??
  18. bobwmunich macrumors newbie

    Jun 8, 2013
    Can't change default app for .odt doc

    Just a short update:

    While messing around with this problem I found I could change the default app to something besides TextEdit, just not I changed it to 'Archive Utility', for example. What Mac OS has against Oo or vice-versa, I know not.
  19. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    This particular issue is caused by Gatekeeper. Open Oo_O (bypassing the Gatekeeper warning if needed, by contextual-clicking and choosing Open). All will be well afterwards.

Share This Page