Can't change file associations in Leopard no matter what I do

Discussion in 'macOS' started by Puzzled, Feb 4, 2008.

  1. Puzzled macrumors newbie

    Joined:
    Feb 4, 2008
    #1
    I can’t change file associations on my system (10.5.1) no matter what I do. For example, I had a simple wish - I wanted to wean mp3 files from iTunes and have them open in QuickTime. I was able to change the association via Get Info - Change All, but this never survived a restart. Every time I rebooted, there was iTunes again. I trashed iTunes, restarted and bingo, there was another application associated with mp3 files - not QuickTime. The system set this new association without ever consulting me, and there was nothing I could do about that. Since then I have tried everything I could find on the web: I tried to set default associations with RCDefaultApp, I cleared all kinds of caches, I tried resetting Launch Services with Yasu, rebuilding Launch Services database with Onyx or manually in Terminal via lsregister, changing type and creator with FileInfo and SuperGetInfo. NOTHING WORKED. Nothing I configured survived more than one restart, the system always defaulted to its own mysterious preferences rather than mine. I’ve spent days trying to fix this issue, with zero result. I am a recent switcher, and I must say this has been a deeply disappointing experience. Setting a file association takes about three clicks in Windows. I’ve had to waste many hours of my time trying to accomplish this simple task on a Mac, and I’m still getting nowhere. I would deeply appreciate any help from Mac gurus. Am I missing something obvious? Does anyone else have this problem, or am I the lucky one?
     
  2. Puzzled thread starter macrumors newbie

    Joined:
    Feb 4, 2008
    #2
    No replies? I still have this problem, and I now believe it is related to FileVault, which I have enabled. I created another account with FileVault disabled, and the file associations seem to be OK. Anyone else using FileVault and having the same problem?
     
  3. fleubis macrumors newbie

    Joined:
    Feb 19, 2008
    #3
    Nope! Not FileVault. Mine has been turned off since I got my iMac. Running Leopard OS 10.5.2

    "Change All" it not highlighted and thus not clickable. I would like Adobe Reader to open *ALL* Acrobat files--not preview.

    This is a toughter nut to crack than first appears.....
     
  4. Blubbert macrumors 6502

    Joined:
    Nov 1, 2006
    #4
    Look for an app called Default Apps. I used it when the Unarchiver kept asociating itself with formats i didnt want it to associate with. Since i used Default Apps, the Unarchver has behaved itself.
     
  5. Puzzled thread starter macrumors newbie

    Joined:
    Feb 4, 2008
    #5
    None of the apps I mentioned in my original post worked (including RCDefaultApp) - I tried them all many times, the resulting settings only survived one or at most two restarts. Most of them are great tools, and they really do what they promise to do, it's just that some gremlin within Mac OS deliberately undoes everything again.

    In the meantime, I have found a lame workaround to at least partially make the computer do what I want it to do. I use File Buddy to search for all files with a particular extension (e.g. mp3), and then change the creator type of the whole bunch to that of the program I want to be associated with these files. E.g. the creator type for QuickTime Player is TVOD. After I changed creator type for every single mp3 file on my computer from "???" to "TVOD" they finally became associated with QuickTime and still remain so. The catch is, this only works for those particular files. Any new mp3 files that end up on your computer will still be opened in whatever program your Mac thinks fit. So I have to repeat the procedure every now and then to include new files.
     
  6. terrafx macrumors newbie

    Joined:
    Mar 24, 2008
    #6
    The easiest way to do this is to go into Get Info on a file with the extension you want to change the default application. Under the Open with: section change to the application you'd like and then click on the Change All button

    Voila

    Cheers

    Nick
     
  7. growlgrowl macrumors newbie

    Joined:
    Apr 24, 2008
    #7
    Problem with RCDefaultApp when restarting

    Puzzled.

    I am having the same problem. RCD will accept the associations and they remain in place until I restart. Then everything is is reset to the Mac default settings.

    Using the Get Info area does the same; reset on restart!!!

    I just have Firefox set to ask me everytime it realises it's not the default and I have to reset my AVIs to VLC from QT after ever restart.

    This obviously isn't a common problem as there doesn't seem to be a well known solution!!!

    I am new to Macs so am finding this a bit frustrating!!!

    I am using OSX 10.5.2

    Grrrrrr
     
  8. wordy macrumors regular

    wordy

    Joined:
    Feb 26, 2008
    Location:
    Toronto
    #8
    Are you logged in as an administrator?

    The fact that the permissions reset every time you restart seems fishy.

    You should try setting up another user account (as an admin) and then see if you can "change all" (to mp3s for example).
     
  9. growlgrowl macrumors newbie

    Joined:
    Apr 24, 2008
    #9
    Possible solution

    Thanks. I set up a new admin account and it seemed to hold on to my preferences.

    Looked up the differences with my own admin account and the only thing seemed to be FireVault was switched on in my own.

    So I've switched FireVault off and the settings seem to be staying.

    Presumably that's not how it should be but it'll do fine for me.

    Grrrrr
     
  10. guiltpop macrumors newbie

    Joined:
    Jun 29, 2008
    #10
    This problem is making me mad...

    I have filevault on and am experiencing this same problem.

    I don't want to turn file vault off, using this feature should not create such an annoying problem like this.

    ARRGGHHH. This is BS Apple!
     
  11. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #11
    Hey guys - I think you're not alone in this issue. The problem, in your case, is an outdated LaunchServices database. This is very easy to fix. Instructions are here.
     
  12. whittaker007 macrumors newbie

    Joined:
    Sep 22, 2008
    #12
    Same here. Most file types are fine, but there are some I can't change no matter what I do. I've tried using Onyx to clear my caches, I've tried changing association in the Finder Open With and Info views. I've tried using RCDefault App. In all cases I am able to select a new default app, but the instant the new app is selected, the old one replaces it. :eek:

    I'm running OS X 10.5 Leopard on a Core 2 Duo Intel Macbook. And I'm not using FileVault. This is the most annoying issue when using a Mac over a PC after not being able to merge the contents of two folders with the same name. And in both cases it shouldn't be difficult to implement.
     
  13. deepclue macrumors newbie

    Joined:
    Feb 19, 2009
    #13
    Fix

    1. Open Automator
    2. Type "Shell"
    3. Drag Run Shell Script into workflow pane
    4. Paste the following, overwriting whatever is there:

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user ; killall -HUP Finder

    5. Save as Application in /Application/Utilities as "LaunchServices Restart"
    6. Go to System Preferences > Accounts, and add LaunchServices Restart to yout Login Items list
    7. You're all set

    I found this workaround here, but I added the "killall -HUP Finder" so Finder can display files with the appropriate icons.
     
  14. enaknivek macrumors newbie

    Joined:
    Dec 23, 2011
    #14
    I registered a MacRumours account specially so I could reply to this post and thank deepclue (and vicariously the original poster he found the idea from). I have FileVault activated and have tried everything to get the file associations to reset from their defaults, all to no avail. I just tried deepclue's automator application and bingo my new associations survived restart! After I restarted the computer, not only had all the default file associations changed to the new ones I chose, the finder window displayed the icons for the new default apps I had selected! Fantastic!

    And I learned how to create apps in Automator, too! Thanks!

     

Share This Page