Can't change file names AT ALL

Discussion in 'Mac Basics and Help' started by garygibsonsf, Jun 6, 2012.

  1. garygibsonsf macrumors newbie

    Joined:
    Jun 6, 2012
    #1
    I've seen similar threads to my problem, but none that appear to address it specifically.

    I have a bunch of files in a folder. Some are greyed out, some aren't. I had no idea why until I tried to change the names of some of them and found I couldn't. They've been like that for a while, though I couldn't tell you how long. I never really thought about it until I had a need to change the names of them.

    When I 'got info' on each of them, I clicked the padlock icon to unlock them. I got a popup window asking me to enter my user password. I then closed the 'get info' window. They were still grey and uneditable. I hit 'get info' again and in every case, each one I had supposedly unlocked was still locked. I was still unable to change the file names.

    If I try and copy them to another folder, it tells me the files are 'in use' by some other application. They aren't. I tried rebooting Finder. No success.

    I tried the same on the containing folders; same results. Files that were already unlocked were fine. I have no idea why some are, and some aren't. This is proving enormously frustrating and I've already wasted half a day searching for and failing to find a solution. I've tried changing the settings of and disabling Time Machine. That didn't work either.
    '
    Some info: the files are contained in a subfolder in Dropbox. I'm running Lion 10.7.3 on a two-year old Macbook. Help!
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Have you checked Finder > select file >> GET INFO >>> Sharing & Permissions yet and seen, if you have proper permissions?
    [​IMG]
     
  3. garygibsonsf thread starter macrumors newbie

    Joined:
    Jun 6, 2012
    #3
    In the Get Info box, I have:

    'GaryGibson (me)' with read and write selected.
    Below that is 'everyone (read only)'.

    I tried switching the second ('everyone') to read and write as well but that doesn't work either.
     

Share This Page