Can't change icons with Snow Leopard

Discussion in 'macOS' started by roughbeast, Dec 30, 2010.

  1. roughbeast, Dec 30, 2010
    Last edited: Dec 30, 2010

    roughbeast macrumors newbie

    Joined:
    Dec 19, 2010
    #1
    I know this has been addressed before, but the answers didn't work for me, so I posted a reply in that thread but got no responses, so I'm starting over.

    With 10.4, all I had to do to change an icon for a folder or website was copy and paste. These were for icons I wanted in my dock to make them easy to find. Otherwise the default seems to be either that ubiquitous satellite dish or a boring documents icon.

    But now, even though I can still do the get info/copy & paste routine, and the new icon shows up in the folder or the desktop, when I drag that icon to the dock it reverts to that crummy satellite dish. When I installed 10.6 on my new iMac, it kept some of my dock icons - the ones I had created - and dumped others. And kept me from creating new ones for the dock. Anybody have an idea what's going on?

    Thanks.
     
  2. lewis82 macrumors 68000

    lewis82

    Joined:
    Aug 26, 2009
    Location:
    Totalitarian Republic of Northlandia
    #2
    Have you tried relaunching the dock? Sometimes icons don't change unless you do it.

    Type this in terminal:
    Code:
    killall Dock

    If it is an app, though, you might need something else. You will most likely have to change the icns file. It is located inside the app (for example, in iTunes, it is /Applications/iTunes.app/Contents/Resources), so you'll have to right-click the app and choose "Show package contents". Be sure to save the original icon in case something goes wrong.

    Now if your icon is not a .icns file, you can use this site to create one: http://iconverticons.com/.
     
  3. roughbeast thread starter macrumors newbie

    Joined:
    Dec 19, 2010
    #3
    Thanks for your reply. On the right side of the dock I have only websites and folders, no apps - I'm OK with the apps icons. It's the generic ones for folders and websites I don't like because I can't easily distinguish between them. Of course I can run the cursor over them, but I'd rather be able to see what I want to click on.

    When I see something like "killall dock" I get scared - like what if I lose the icons I already have and everything turns into satellite dishes? And besides, I'm not at all proficient enough even to know what you mean by "terminal," and there's no way I could ever write my own icons.

    Come to think of it, there's another icon problem I'm having with Snow Leopard. When I drag a URL to my desktop and click get info, very often instead of the usual window with the icon on top next to the website name - the familiar vertical box that lists Kind, Size, Where, Created, etc. - I get a horizontal window entitled Page info with the URL and tabs for general, media, feeds, permissions and security - that's what happens for example with this site. So there's no get info display with an icon that I can paste over with an icon of my choosing - thus if I want this site in my dock to get to easily, I have to hunt for it among all the satellite dishes. This also never happened with 10.4. I must be doing something wrong, or Apple must have changed something.
     
  4. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #4
    All that typing "killall Dock" in the Terminal does is quit the Dock, which causes it to relaunch itself automatically. You will achieve the same result usually by restarting the computer. It cannot and will not affect your actual document or folder icons, but will affect their display in the Dock, correcting any previously cached image (from before you applied your custom icons).

    As for the second issue, it sounds to me like you're hitting Get Info while still in Safari (or whatever browser you use). Make sure the menu you use to choose Get Info says Finder, not something else. The screen you describe doesn't exist in the Finder, so it's obviously not that.

    jW
     
  5. Elucidesign macrumors newbie

    Joined:
    May 13, 2011
    #5
    It works, sometimes.

    I wish I knew what. and try a restart.... ; ) ( I know, silly, but maybe a cache is flushed or something?)

    I'm running a clean install of 10.6.7 and no programs which *should* interfere with the normal GUI. I'm a graphic designer and all this *should* be old hat.

    Changing icons didn't always work... but now it does. No matter what combination of copying/pasting, changing file formats, trying .icns files. Nothing. Sometimes.

    The file whose icon I wish to change DOES increase in filesize when an image is pasted into its Get Info icon header, BUT... yesterday it didn't work, today it does.


    Best advice, Restart, Relaunch Finder with Force Quit... Perhaps you'll get lucky as I did.

    If any gurus can speak definitively as to why it now, sometimes, works... I'd love to know.
    Sef.
     

Share This Page