Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Ben J.

macrumors 6502a
Original poster
Aug 29, 2019
681
366
Oslo
I just bought a used MBP. 2013 w/Catalina.
The last user had erased it and installed fresh with an account named 'user'.
I've created a new account with my name, linked it to my appleID account, deleted the 'user' account, and changed the name to 'Ben's MBP' in 'sharing' in system settings.

The MBP still shows as 'user's macbook pro' on my other devices.

Any thoughts?
 

arw

macrumors 65816
Aug 31, 2010
1,100
859
The name is set in several variables.
In Terminal paste:
Code:
sudo scutil --set HostName "Ben's MBP" && scutil --set LocalHostName "Ben's MBP"
&& scutil --set ComputerName "Ben's MBP"
then reboot

EDIT: correction: 'LocalHostName' mustn’t contain any other characters than letters, numbers and "-"
 
Last edited:

Ben J.

macrumors 6502a
Original poster
Aug 29, 2019
681
366
Oslo
The name is set in several variables.
In Terminal paste:
Code:
sudo scutil --set HostName "Ben's MBP" && scutil --set LocalHostName "Ben's MBP"
&& scutil --set ComputerName "Ben's MBP"
then reboot
Thanks, arw.
That worked right away.
(I got a 'LocalHostName failed bad argument' or something, but it worked.
Thanks again.
 

arw

macrumors 65816
Aug 31, 2010
1,100
859
Thanks, arw.
That worked right away.
(I got a 'LocalHostName failed bad argument' or something, but it worked.
Thanks again.
You’re right, when setting 'LocalHostName', this one mustn't contain an apostrophe or space (or any other special characters except "-").
I generally avoid special characters so I never noticed.
It is the .local Bonjour name (a.e. for Airdrop).
You can set it a.e. as:
Code:
sudo scutil --set LocalHostName "Bens-MBP"
 
Last edited:

Ben J.

macrumors 6502a
Original poster
Aug 29, 2019
681
366
Oslo
Your right, when setting 'LocalHostName', this one mustn't contain an apostrophe or space (or any other special characters except "-").
I generally avoid special characters so I never noticed.
It is the .local Bonjour name (a.e. for Airdrop).
You can set it a.e. as:
Code:
sudo scutil --set LocalHostName "Bens-MBP"
Thanks again. That last command completed the rename - the old name is now gone everywhere. I tried it with a space after Ben, but that also resulted in ' failed argument'. But, all good.
 
  • Like
Reactions: arw

Gudi

Suspended
May 3, 2013
4,590
3,265
Berlin, Berlin
System Preferences > Sharing > Computer Name:
System Preferences > Sharing > Edit...
System Preferences > Network > Options... > WINS > NetBIOS-Name:

Should all work without the Terminal.
 
  • Like
Reactions: circatee

Ben J.

macrumors 6502a
Original poster
Aug 29, 2019
681
366
Oslo
System Preferences > Sharing > Computer Name:
System Preferences > Sharing > Edit...
System Preferences > Network > Options... > WINS > NetBIOS-Name:

Should all work without the Terminal.
Had a quick check - it seems you're right.
Thanks.
 

arw

macrumors 65816
Aug 31, 2010
1,100
859
I always had it automated via script, but for the sake of completeness and future queries, these are the entries for Ventura:

System Preferences > General > Name
System Preferences > General > Sharing > Hostname > Edit (no special characters except "-")
System Preferences > Network > [AdapterName] > Details > WINS > NetBIOS name
 
  • Like
Reactions: Ben J.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.