Can't Change Wallpaper on 2.0

Discussion in 'iPhone' started by chris1016, Jul 10, 2008.

  1. chris1016 macrumors member

    Joined:
    Dec 30, 2007
    #1
    Hey everyone,
    I upgraded my jailbroken (not unlocked) 1.1.4 iPhone to 2.0 this morning. Besides the slow-as-glaciers syncs and buggy apps that constantly crash (Google, I'm looking at you), I encountered another problem: I can't change my wallpaper. I've tried practically everything in the Wallpaper folder and my photo albums and it's stuck on one. Does anyone have any idea as to what's wrong or what I should do?
     
  2. tkeefe67 macrumors newbie

    Joined:
    Jul 10, 2008
    #2
    no idea, but I did just try to change my wall paper and it worked just fine. But I did not upgrade from unlocked.
     
  3. ichii macrumors 6502

    ichii

    Joined:
    Sep 20, 2006
    #3
    i have the same problem with 3g iPhone, at first it worked and showed my background, but now it doesn't I just have the battery level when i wake it from sleep. a^_^ it's because I had it charging
     
  4. buccsmf1 macrumors 6502

    Joined:
    Mar 18, 2008
    #4
    same thing happened to me. wallpaper is stuck on the wallpaper from my jailbroken iphone...
     
  5. GamecockMac macrumors 6502a

    GamecockMac

    Joined:
    Oct 20, 2005
    Location:
    Columbia, SC
    #5
    I'm trying to find out a little more about this bug that I've seen mentioned in a few threads.

    Is anyone who didn't upgrade from a JAILBROKEN iPhone having this problem? Is anyone who upgraded an iPod touch having this problem?
     
  6. KittyToy macrumors 6502

    KittyToy

    Joined:
    Sep 6, 2007
    Location:
    Davenport
    #6
    I change mine constantly with no problems, but my iphone hasn't been hacked since 1.1.4.....not to mention my carrier logo still says my name that is the only hack that stayed after 3 restores and the upgrade to 2.0.
     
  7. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #7
    No problem on this end; then again I wasn't JB on my v1 iPhone...Sorry:(
     
  8. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #8
    Same here.
     
  9. betovarg macrumors newbie

    Joined:
    Jul 22, 2008
    #9
    I also recently upgraded to 2.0, but in my ipod touch, 16gb. After i jailbreak, i loaded my backup from itunes, wich actually, put the same background I had in the lock screen before. Now i cant change it. Ive tried changing it for images downloaded from safari and images i got in sync, but i cant change it. I believe it can be related to permissions? as it did with the mail application, that actually did not work when i updated to 2.0. (had to change the permissions in order for it to work)

    I hope this info might help, i dont like my current background :p
     
  10. ejrizo macrumors 6502

    ejrizo

    Joined:
    Jun 26, 2007
    Location:
    Los Angeles
    #10
    you are not the only one... a friend of mine came to me with the same problem since i jailbreaked her phone for her... she upgraded to 2.0 and has the same issue... so do you solve it?? simply a restore? or do you have to get rid of files somewhere else?
     
  11. chris1016 thread starter macrumors member

    Joined:
    Dec 30, 2007
    #11
    I upgraded to the official 2.0 for the first gen iPhones, and instead of restoring from a backup, I just created a new phone and that solved the problem. I know it's a hassle, but you all could try restoring and creating a new phone?
     
  12. Mxsix macrumors member

    Mxsix

    Joined:
    Dec 28, 2006
    #12
    I have the same problem. Jailbroke 1.1.4, upgraded to actual 2.0 and can't change it. Anyone find a fix besides starting fresh?
     
  13. betovarg macrumors newbie

    Joined:
    Jul 22, 2008
    #13
    Ahhhh, I was hoping this was not the way to fix it. Its a bummer to have to install all over again. what about through SFTP?
     
  14. LiquidDonut macrumors newbie

    Joined:
    Jul 2, 2007
    #14
    i know this is an old thread but I finally solved the problem on my phone and figured I would share. Just SSH into /private/var/mobile/Library and in there you will find a LockBackground.jpg file, I just deleted it and now I can change my wallpaper again.
     

Share This Page