Can't click ANYTHING!

Discussion in 'macOS' started by esker, Aug 5, 2009.

  1. esker macrumors newbie

    Joined:
    Aug 5, 2009
    #1
    About 10 minutes ago I was transferring some files from a USB stick when my Macbook just stopped responding to the click-pad. I can't right/double-click on anything! The cursor works fine and I can move it around but if I hit the clickpad, nothing happens... I can't get into anything, change anything...

    I don't know what to do. I tried using the trackpad to click instead but all that does is give me a lasso tool and still can't click anything but it selects icons on my desktop. It also just selects the top bar automatically but I can't click on anything in the menu.

    I thought it was my hardware but I plugged in a mouse and still nothing! I can left-click with the mouse but not right-click. I've tried rebooting and nothing changed.

    It's like my right-click is constantly pressed down. But it's not physically.

    Also, when I leave it alone it tries to go into the screensaver but constantly comes back out again, so it results in flashing between Flurry and my desktop.

    Also, my keyboard is working fine.


    Please help? I have NO idea how to fix anything if my right-click isn't working!!
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Have you repaired Permissions with Disk Utility yet?

    Have you gone to System Preferences and checked the Mouse/Trackpad and even Exposé preferences?
     
  3. esker thread starter macrumors newbie

    Joined:
    Aug 5, 2009
    #3
    I can't do any of that because I can't click on *anything* to open any program or file. Without the ability to click/open things, I'm not sure how to get into those areas... :(

    I can hover the cursor over and click, but nothing happens. Not with the clickpad or an actual mouse.

    I can't use keyboard shortcuts to access menus because the F-keys are not working. When I press F-1 to F-5, it just either changes the volume or brightness. (This is WITHOUT pressing anything else. I don't have to hold down cmd or option or anything. It's not supposed to do this either.)

    ETA: thru trial and error, I have figured out that I can click on things ONLY when I hold CTRL + double-tap on the trackpad. Now, that I can do this... How would I go about changing everything back to default click settings???


    ETA2: I've checked preferences and everything is normal except that the F-keys thing was unchecked. I re-checked that. But still I can't find anywhere to modify the preferences for what's happening now. There's no "reset" to default options. And no matter what I check/uncheck in the mouse/trackpad preferences, nothing solves my problem.

    I guess I will look for permissions though I'm not even sure what that does....
     
  4. esker thread starter macrumors newbie

    Joined:
    Aug 5, 2009
    #4
    Have you repaired Permissions with Disk Utility yet?
    Yes. Nothing changed.

    Have you gone to System Preferences and checked the Mouse/Trackpad and even Exposé preferences?

    Yes, both.

    I've also reset the system preferences (as best I could figure out: by deleting the file and restarting) and I've done SMC and PRAM resets.
    Nothing has changed at all :(

    Does anyone have any other ideas???
    Or is this a case of having to bring it in, pay lots of money & have them restore it for me? :(

    Please help.
     
  5. Surfer1990 macrumors newbie

    Joined:
    Aug 16, 2009
    #5
    Same Problem

    I just started having this exact same problem a few hours ago or so. Just as you described, nothing can be clicked on for me. The only reason I'm still able to use this computer right now is I can make it click by tapping the pad with one finger. But it's still obviously annoying and inconvenient. Has anybody else had this problem before? And if so, do you know any possible solutions? For me, it will just be like this, then randomly start working properly again, but then the problem will just start right back up again.

    Edit to add: My Mighty Mouse works, though. It's just my trackpad, which I usually prefer to use, doesn't work properly. Edit: Not anymore.
     
  6. Surfer1990 macrumors newbie

    Joined:
    Aug 16, 2009
    #6
    Okay, now my Mighty Mouse has lost its ability to click. :(
     

Share This Page