Cant click links?

Discussion in 'Mac Basics and Help' started by marine610610, Apr 10, 2007.

  1. marine610610 macrumors regular

    Joined:
    Mar 23, 2007
    #1
    I have what i think will be a simple fix for you guys. When i am checking out certain pages i cannot click on all of the links? It never shows the little hand to click, it just keeps shwing an arrow, while other links on the page work just fine. I pulled the same page up on my PC and i can click all the links just fine. Any ideas?
     
  2. Temujin macrumors 6502a

    Temujin

    Joined:
    Oct 1, 2005
    Location:
    Copenhagen
    #2
    You got a link for one of the sites that causes problems?
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Also, what app (browser) are you using? Have you restarted recently? Do you have any theme changers installed? :)
     
  4. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
    #4
    And if these aren't your problem, a disk permission repair (in Disk Utilily) never hurts...
     
  5. marine610610 thread starter macrumors regular

    Joined:
    Mar 23, 2007
    #5
    I am using Safari. This MBP is about four days old so i hope it dose not need any repairs as of yet. The website i was referring to is www.townhall.com. Its a site a college class of mine is using. Anyway i can click most of the links on the page, but i cannot click the ones immediatley to the right of the picture it opens with. I turn the the PC sitting right next to me and i can click on them. Any ideas?
     
  6. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #6
    This happens to me when I try to view store ads via shoplocal. You might want to try using FireFox for those pages. It only seems to be an issue in Safari. My issue eventually resolved itself. :rolleyes:

    Right...
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    There was a bug in Safari a while ago whereby links would disappear when a cursor was run over them. I found resetting Safari from the Safari menu always fixed this, but it could come up every few months or so. Make sure all system updates are installed and maybe try the reset. The links at your site work for me in Safari 2.0.4. :)
     
  8. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #8
    The links don't disappear. They are still visible to click on. The small pointing hand still shows up as well. Clicking on the just gets no result.
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    Yeah, I know, but a reset might still help and the problems may be related. FWIW, marine610610 says it never shows the little hand.
     
  10. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #10
    My suggestion is still to use FireFox for those sites.
     
  11. marine610610 thread starter macrumors regular

    Joined:
    Mar 23, 2007
    #11
    Resetting Safari did not do it for me. I wonder what the deal is? Ill probably end up loading firefox as well, i dont need to find myself unable to access sites when i really need them. Thanks for checking again fellas...
     

Share This Page