Can't compose new email in 3G since iOS4

iamshopping

macrumors newbie
Original poster
Jul 27, 2010
3
0
I haven't been able to compose a new email since I updated my 3G to the iOS4. I am receiving emails just fine but when I touch the compose (or create) icon, the icon briefly lights up and then does nothing. I've gone through every setting on the phone and can't figure out if there is anything I can change. Anyone else have this issue or know how to resolve? Thanks, in advance.
 

xdext3r

macrumors newbie
Jul 26, 2010
23
0
iOS4 runs horribly slow on the 3G ... downgrade to iOS3 or call apple support and get them to ship you a new phone with OS3.x installed on it. And dont upgrade ...
 

CSMchris376

macrumors regular
Mar 13, 2010
232
0
Illinois
I have iOS4.0.1 on my 3G, and while there are some slow points, I wouldn't say it runs horribly slow. I also have no problems with the mail app or sending mail from any of my accounts, so it is not an iOS4 issue.

If the 3G is not in warranty, the cost of a replacement phone would be almost as much as a new iPhone 4, so it doesn't make sense to do what you suggest.
 

iamshopping

macrumors newbie
Original poster
Jul 27, 2010
3
0
Hi again - I just tried to delete the account and recreate it...to no avail. The compose email won't work when I touch an email address in contacts either. It WILL work, if I touch an email address on a website. I guess I will be paying a call to the genius bar. Thanks for everyone's suggestions.

- J
 

iamshopping

macrumors newbie
Original poster
Jul 27, 2010
3
0
Thanks, AppleJuiced (love the name!). Went to restore and got a message about 4.0.1 update being available so I updated and voila...problem solved!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.