Can't 'Connect As' on Network / Sharing

Discussion in 'Mac Basics and Help' started by agatenby, Jul 29, 2008.

  1. agatenby macrumors newbie

    Joined:
    Jul 29, 2008
    #1
    Trying to share files between my MBP and iMac. Created users on each for sharing, and all works fine on my iMac. However on my MBP, i see the iMac, but it just says connecting (never connects), and when i click the 'Connect As' i doesn't load the normal login screen - it does nothing.

    Any help appreciated. Thanks.
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    That's odd. Do you have file sharing on on both computers?
     
  3. baummer macrumors 6502a

    Joined:
    Jan 18, 2005
    Location:
    Southern California
    #3
    Do you have file sharing enabled on the iMac?
     
  4. agatenby thread starter macrumors newbie

    Joined:
    Jul 29, 2008
    #4
    Yes, on both, and i have also checked all other settings too. Appletalk is active, and i have even tried with guest accounts but still no luck connecting from my MBP to the iMac.

    May give Apple a call.
     
  5. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #5
    You may have a problem with your keychains file on the MBP. Run KeyChain Access (Applications/Utilities/Keychain Access and repair your keychains.

    Then on the iMac, turn off file sharing and then turn it back on.

    Reboot the MBP. See if that helps.
     
  6. agatenby thread starter macrumors newbie

    Joined:
    Jul 29, 2008
    #6
    A user on the apple support site suggested to allow all on the firewall on the iMac. This worked! I was then able to save my login details to my keychain on the MBP and turn the firewall back on.

    Thanks for your help guy's.
     

Share This Page