Can't connect as using Apple ID

Discussion in 'OS X Mountain Lion (10.8)' started by richard13, Aug 26, 2012.

  1. richard13 macrumors 6502a

    Joined:
    Aug 1, 2008
    Location:
    Mill Creek, WA
    #1
    In the past I was able to connect to my iMac from my MacBook Pro and vice-versa using my Apple ID but now when I click on my iMac from Finder it says "Connection Failed". If I try to manually connect with Command-K using afp://<address of my iMac> I get the "Enter your name and password for server" box. But when I choose "Using an Apple ID" and click Connect, the box shakes like the login box when I've entered the wrong password.

    Things I have tried:

    • Disassociated/Re-associated my Apple ID to my computer accounts
    • Enabled "Back to my Mac" in iCloud System Preferences on both computers
    • Disabled/Re-enabled File Sharing on both computers
    • Re-authorizing my computers within iTunes
    • Repair Disk Permissions in Disk Utility on both computers
    • Rebooting

    Got any other ideas?
     
  2. richard13 thread starter macrumors 6502a

    Joined:
    Aug 1, 2008
    Location:
    Mill Creek, WA
    #2
    Wow... 562 views and no replies :(

    So, is this working for you all and don't know why I'm having trouble? Or is it also broken for you and you're unconcerned? ;)
     
  3. bfdill macrumors newbie

    Joined:
    Jul 20, 2011
    #3
    I was able to get this working by making sure the Apple Id email address belonged to a contact and then adding that contact to the Screen Sharing service's user access list.

    For one of my machines, it wouldn't accept the contact card that naturally had the Apple Id's email address (because it was associated with login account a.k.a. an administrator so why add it???). To work around this I added a contact called My Apple Id with a home email address = Apple Id. Then I added My Apple Id to the Screen Sharing service's user list and BAM, sweet success :)

    I hope this helps, good luck!
     
  4. bfdill macrumors newbie

    Joined:
    Jul 20, 2011
    #4
    It looks like there's a sharing only account type that was created for my Apple Id contact. That account is associated with the Apple Id and is the one that's in the Screen Sharing now...

    Perhaps there's a glitch that's preventing the Apple Id of the primary account from working? Not sure if this helps at all, but I thought I'd mention it.
     
  5. richard13 thread starter macrumors 6502a

    Joined:
    Aug 1, 2008
    Location:
    Mill Creek, WA
    #5
    Hey. Thanks for posting what you've tried to get this to work.

    Here's my story...

    After the lack of responses here in the forum I decided to try and get help from the source.

    I first called Apple Care to see what they had to say about this. I spoke to three separate people, none was really able to help me. The last person was a 2nd tier guy who said that what I was trying to do was not supported. When I tried to explain that I was getting errors in the Console that sounded like it should work but couldn't he told me to ignore that. Similarly, my questions about why would Apple have connecting as an Apple ID as an option in the user interface at all if it wasn't supposed to work were similarly rebuffed. Overall, I think that these guys are trained to not speak geek to customers.

    Anyway, after I got off the phone it miraculously starting working! I was able to connect with my Apple ID! Coincidence? I don't know. I decided that there must be something on Apple's end that flipped the switch so I experimented with deleting and then restoring various keychains, certificates, etc. I never did figure out why it suddenly started working.

    Being told that it wasn't supposed to work got me a little worried so I did a clean install and as expected, connecting as an Apple ID was broken again. But I was still a little curious and not 100% satisfied with the answers I had gotten so I made an appointment with the Genius Bar at my local store. The guy I met there listened to me, checked my settings, explained that what I was trying to do was not really supported for my specific scenario. It might be made to work in other scenarios but to not worry because connecting as a Registered User rather and an Apple ID is the proper way for connecting to remote shares. In fact, he said if it ever starts working again on its own like that, that I should come back to the store to show him because it's not supposed to work. I don't know if that's completely true but he was the friendliest of the bunch and his story seemed believable and plausible.

    I haven't tried to make this work with an Apple ID since. I'm not going to bother with it for now and especially since it seemed glitchy and I don't really know what it's doing behind the scenes. I'm more concerned about security than convenience.

    So, good luck to you. If you have any questions about my experience I'd be more than happy to elaborate.
     
  6. RMac21 macrumors newbie

    RMac21

    Joined:
    Jun 27, 2015
    #6
    Hello all

    I have been going trough the same issue for days now and I found the catch.

    Here is how I made it to work and connect using apple IDs. I see I am very very late with the post and probably this has been figured out by now but still.

    I did not create any extra accounts on my mac. Simply go into to the system preferences, sharing and turn it on. Then click on the plus sign and choose from a person from contacts that you want to share folders with. It will then ask you to set a password for that user. You can leave it blank or type in anything since it does not matter because the user wont get prompted to input the password. That is all you can now connect using apple ID!
    As a side note, you can notice extra account has been automatically created under users and groups as "Share Only" account. I believe you need to have persons apple ID assigned within the contacts.

    Hope this helps to someone.
     
  7. richard13 thread starter macrumors 6502a

    Joined:
    Aug 1, 2008
    Location:
    Mill Creek, WA
    #7
    Thank you for your post, RMac21! Yea, it's been a few years since and I've completely lost my burning desire to make this work. But if I ever get curious again I will try your idea. :)
     
  8. nutellacrepe macrumors newbie

    Joined:
    Nov 28, 2016
    #8
    Hi RMac21 - Your post helped me in that I thought I should just delete the users and re-do them. So on the machine I wanted to connect to, I went into "File Sharing" and removed all the "Shared Folders" and all the "Users". I just want to connect my work laptop to my home machine, to get to the external drives on the home machine, so this setup probably wouldn't work for a larger network. But that fixed the "shaking wrong password" login screen, when I know the password is correct (because I'm able to login to the destination machine as it's right next to me...). So, deleting everything and then relogging in worked for me. I had tried rebooting (big hassle with lots of hard drives and projects open) but that didn't help.
     

Share This Page