Can't connect iMac to internet after waking from sleep

Discussion in 'iMac' started by SylviaW, May 18, 2009.

  1. SylviaW macrumors newbie

    Joined:
    Dec 11, 2008
    #1
    Hi, all.

    After about 8 months of flawless performance, I now have trouble connecting to the internet almost every time the computer wakes from sleep.

    What happens: Firefox, already running, can't connect to any site.

    I am using Firefox 3.0.10 on my iMac (OS 10.5.6).

    My internet provider is Comcast.

    I have a Comcast-supplied RCA modem, model DCM425C.


    What does not work:
    -- Only turning off and on the modem.
    -- Only unplugging and replugging the modem power.
    -- Only restarting the iMac.


    What does work:
    -- Turning the iMac off (restarting or shutting down, either works) and on, plus + unplugging and replugging the modem power cord in the back of the modem.


    I think this started about the time I dragged all my son's Halo files to the trash and emptied it.

    But I could be wrong.

    Please tell me how to troubleshoot this. (And feel free to suggest a better forum for my question.)

    Many thanks.

    SylviaW
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    If you connect wirelessly to the modem or a router you could try to turn off Airport and the turning it on again.

    If you connect by cable to the router, have a look at the Network settings (System Preferences).

    Also, how do you connect to the internet?
    Does you iMac dial into the net via PPPoE or does the router (if you have one, it's not the same as the modem) do that for you?
     
  3. SylviaW thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    #3
    spinnerlys:

    If you connect wirelessly to the modem or a router you could try to turn off Airport and the turning it on again. If you connect by cable to the router, have a look at the Network settings (System Preferences).

    I don't use wireless on this iMac. Never have.

    Also, how do you connect to the internet? Does you iMac dial into the net via PPPoE ...? ​

    I don't know. But give me the steps to find out and I will report back.

    Thanks very much.
     
  4. SylviaW thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    #4
    I should add:

    I have unchecked the option to "put hard drive to sleep when possible."

    Have set the energy saver options to never put anything to sleep.

    I hoped that would work. But last night, I put the machine to sleep (Apple menu), and when I woke it this morning (space bar) -- again, could not connect.

    For the nth time, I unplugged the power from the back of the cable modem. Restarted the computer (Apple menu). As the computer was shutting down, I plugged back in the modem. When the computer restarted, I was able to connect, no problems.

    I am counting on you whizzes to figure this one out!!

    Thanks.
     
  5. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #5
    Have you the following hardware setup?

    Plug to Modem to iMac:

    [​IMG]


    or

    Plug to Modem to Router to iMac:

    [​IMG]



    Also have you looked into you Network Preferences?

    Have you setup a Location?

    [​IMG]

    [​IMG]


    If your setup is using DHCP, meaning you haven't setup the IP and such, it'll take a while for the OS to communicate with the modem to get a proper IP and to start surfing again.
    If you set it all up manually, the problem of yours might disappear.
     
  6. SylviaW thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    #6
    spinnerlys:

    My hardware setup is: cable to modem to plug to iMac. (Remember, I have no router.)

    My Apple menu does not have a Location choice where yours does. (OS 10.5.6)

    My Network Preferences are indeed set to DHCP. I love the words "problem might disappear." Please give instructions for setting up manually.
     
  7. SylviaW thread starter macrumors newbie

    Joined:
    Dec 11, 2008
    #7
    spinnerlys:

    Wait. I may have found the culprit. More tomorrow after a few hours of testing.
     

Share This Page