Resolved Can't connect magic mouse... help please

Discussion in 'Mac Accessories' started by dannyg86, Oct 20, 2014.

  1. dannyg86, Oct 20, 2014
    Last edited: Oct 20, 2014

    dannyg86 macrumors regular

    dannyg86

    Joined:
    Apr 11, 2014
    #1
    Hey guys/gals.

    I recently got my magic mouse back, from my Dad who was using it on his iMac 27" temporarily, and am trying to re-pair it to my iMac 2011 21" that is running on the latest public version of Yosemite.

    I have reset my pram etc, taken out the batteries from the mouse, put new batteries in, turned it on/off.. etc etc.. but it is not showing up when I run the add mouse assistant or under the bluetooth preferences pane.

    Any ideas how I can get this thing to be discoverable again :rolleyes:?

    Thanks!

    EDIT: Clicking the mouse like crazy got it to show up under the bluetooth utility, but it would not pair. Clicking like crazy again whilst bluetooth was off, then turning bluetooth back on a second or two after got the mouse to show up with it's correct readable name, and I was able to pair.

    Hope this helps someone in future
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Did you try to re-pair the device?

    If its not showing up, maybe its not working.
     
  3. dannyg86 thread starter macrumors regular

    dannyg86

    Joined:
    Apr 11, 2014
    #3
    Oh the mouse is definitely working. Was working perfect up until yesterday with my Dad's iMac.

    I managed to get it to show up a few times by turning it on and clicking it like crazy (left clicking I guess). It showed up under it's bluetooth address xxx-393-etc but would not pair. I recall having issues switching Apple bluetooth mouse/keyboards between devices in the past, but cannot recall how I managed to slay the beast..

    Thanks

    EDIT: Now working!
     

Share This Page