Can't connect my MacBook Pro 15" to LED TV

Discussion in 'MacBook Pro' started by LoganRusling, Sep 16, 2011.

  1. LoganRusling macrumors newbie

    Joined:
    Sep 16, 2011
    #1
    I have a 52" LG LED TV, and a MacBook Pro 15."

    I have the MonoPrice Mini DisplayPort to HDMI cable, but whenever I connect it to my TV I get the No Signal icon.

    I've tried setting it to "Just Scan" mode and other options, but it won't work.

    Actually, the "Just Scan" mode is grayed out, so I can't select it.

    I've tried 16:9, Set By Program, 4:3, Zoom, Cinema Zoom 1, but none of them work.

    Is there any way to fix this?
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    It sounds like you have it on the wrong input. If not, try "detect displays" in the displays section in system prefs.
     
  3. LoganRusling thread starter macrumors newbie

    Joined:
    Sep 16, 2011
    #3
    Wrong input?

    I've tried "Detect Displays" many times, but to no avail.

    Oddly, whenever I connected both of the cables I have to my TV for the first time, it worked. But whenever I disconnected them and tried to use them on another TV it didn't work.

    After that I haven't been able to make it work with any of my LED or LCD TVs.

    Also I've tried connecting the cable to all of the different HDMI jacks on my TVs. None of them work.
     
  4. urimils macrumors newbie

    Joined:
    Aug 17, 2011

Share This Page