Can't connect to airport, unless network unprotected

Discussion in 'iPod touch' started by pyrogerg, Feb 15, 2011.

  1. pyrogerg macrumors newbie

    Joined:
    Feb 15, 2011
    #1
    I am puzzled. I can't get my iPod Touch 4th generation to connect to my home network unless I remove the network's password protection (Time Capsule router). My computer and my next-door neighbor are able to access the network with password protection active, but not the iPod. I just get an error message "Unable to join the network 'Pyrogerg's network'." I've tried changing the security setting from WPA2 to WPA/WPA2, but that didn't help. Any ideas?
     
  2. misterpasta macrumors member

    Joined:
    Apr 24, 2007
    #2
    Reset Network Settings

    Reset network settings by tapping Settings > General > Reset > Reset Network Settings.
    Note: This will reset all network settings, including passwords, VPN, and APN settings.

    http://support.apple.com/kb/TS1398
     
  3. pepi macrumors member

    Joined:
    Dec 13, 2010
    #3
    I had to do this the other day because my office WAN would not work anymore. It fixed the problem but what a PITA getting all my other security code back :(
     
  4. pyrogerg thread starter macrumors newbie

    Joined:
    Feb 15, 2011
    #4
    Steps taken so far

    I should have mentioned in my original post that I have:
    • Reset network settings on iPod
    • Power-cycled iPod
    • Reset Time Capsule
    • Changed network security from WPA2 to WPA
    • Re-created network
    These steps failed to resolve the issue. Here's some other relevant information. My original 4th generation iPod Touch worked on the network until one day this issue appeared. Since then, that iPod was replaced with a new one by Apple Care for other reasons. The issue persists with the new iPod. Apple Care has shuffled me back and forth between iPod specialists and Airport specialists, who don't seem to communicate much with each other. In spite of not being able to connect to my password protected home network, the iPod can connect to other password protected networks. Mysteriouser and mysteriouser
     
  5. herdnerfer macrumors 6502

    Joined:
    Feb 12, 2011
    Location:
    Saint louis, MO
    #5
    Wifi channel

    You may want to try changing the channel the router broadcasts on, especially if you are 802.11n. I had a similar problem and switching to a lower channel (I think I am using 3) worked for me!
     
  6. Brucewl macrumors 6502

    Brucewl

    Joined:
    Sep 15, 2010
    #6
    So, did your router had set the IP address filtering and KSG?
     

Share This Page