Can't connect to App Store or Safari on 4th Generation Touch

Discussion in 'iPod touch' started by Samelson03, Jul 25, 2011.

  1. Samelson03, Jul 25, 2011
    Last edited: Jul 25, 2011

    Samelson03 macrumors 6502

    Joined:
    Mar 8, 2007
    #1
    I've been having problems with connecting to the App Store and Safari. I have 2 out of 3 bars and when I try to connect to the App Store it just sits there and loads but doesn't go beyond that point.

    EDIT: I probably should've mentioned that I can get through sometimes. I just tried again and it said I wasn't connected at all. So, I went to Settings and then Wi-Fi and it shows I'm connected there. I have absolutely no signal though. Very weird!
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Are you using your home internet, a friend's, or maybe a WiFi hotspot? Can other iOS devices on the same network connect? Also, what version of iOS do you have on the iPod touch?
     
  3. Samelson03 thread starter macrumors 6502

    Joined:
    Mar 8, 2007
    #3
    I'm using my home internet. My brother can connect using his iPad or his iPhone 4 just fine. How do I check to see what version of iOS I have?
     
  4. jonrando macrumors 6502a

    Joined:
    Jun 22, 2011
  5. Samelson03 thread starter macrumors 6502

    Joined:
    Mar 8, 2007
    #5
    I have version 4.3.4. Maybe it's my wireless router? It is pretty old.
     
  6. wngster macrumors member

    Joined:
    Jul 23, 2011
    Location:
    somewhere
    #6
    ok since its your home internet what i do is disconect my ipod reconnect and its better then before:D
     
  7. Samelson03 thread starter macrumors 6502

    Joined:
    Mar 8, 2007
    #7
    You mean disconnect my wireless router and then plug it back in after a few seconds?
     
  8. jonrando macrumors 6502a

    Joined:
    Jun 22, 2011
    #8
    Try that.
     
  9. Samelson03 thread starter macrumors 6502

    Joined:
    Mar 8, 2007
    #9
    Yeah, that didn't work. This is so incredibly frustrating!!!
     
  10. Samelson03 thread starter macrumors 6502

    Joined:
    Mar 8, 2007
  11. tablo13 macrumors 65816

    tablo13

    Joined:
    Jul 29, 2010
    Location:
    Edmonton, Alberta, Canada
    #11
    Could it be parental restrictions in settings?
     
  12. YEEZY macrumors member

    Joined:
    Jul 29, 2011
    #12
    iPod touches always seem to be buggy with WiFi. I think it should be fine.

    Maybe if you log in to your router you can find something.
     
  13. jonrando macrumors 6502a

    Joined:
    Jun 22, 2011

Share This Page