Can't connect to iMac over home network

Discussion in 'Mac Basics and Help' started by Flash6, Jun 26, 2010.

  1. Flash6 macrumors newbie

    Joined:
    May 24, 2008
    #1
    I have an iMac (24" 2.8 C2D, 4G RAM, ver. 10.5.8) that I have connected to a home LAN via a Belkin G router. It is connected to 2 PCs (XP) via a wired connection and my daughter's new 15" MBP running 10.6 (read: REALLY jealous dad) via the wi-fi/AirPort connection.

    The problem is that I can't seem to access the iMac from any of the computers, even though it appears in the Finder and the Network Places lists on the MBP and PC's.

    The connection will, however, work the other direction. The MBP will show up in the iMac Finder and I can log in using my daughters user name and password, and I can transfer files from the iMac to the MBP once connected. The PC's do NOT show up in the iMac Finder, but I can connect directly via Go>Connect to Server. Once connected they appear in finder and I can transfer files.

    BTW, the two PC's DO show up in the Finder window on the MBP without having to use the Connect to Server function (and they appear with their computer name instead of the IP as they do on the iMac)

    I've set up File Sharing for my account, and enabled both AFP and SMB.

    Any thoughts?

    I have not tried connecting when logged in as another user, but will try that later and post the results.

    Thanks

    t
    o
    m
    <><
     
  2. ahm macrumors member

    Joined:
    Feb 14, 2009
    #2
    Would it help to manually connect?:

    Finder>Go>Connect to Server>Server Address: smb://computer_name_here
     
  3. Flash6 thread starter macrumors newbie

    Joined:
    May 24, 2008
    #3
    Tried to do that with the IP address and it also failed. I'll give it a try with the computer name instead of the IP.

    I also tried with the iMac logged in as a different user but got the same results.

    I should mention that when I try to "Connect" or "Connect as" from the MBP I don't ever get a prompt/option to enter a user name or password.
     
  4. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #4
    Have you checked your firewall? That is likely the problem.
     
  5. Flash6 thread starter macrumors newbie

    Joined:
    May 24, 2008
    #5

    Funny you should mention that............

    Last night I kept digging and ended up changing a firewall setting and everything seems to work well now.

    Thanks for everyone's help!!
     

Share This Page