Can't connect to internet (O2)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Vazza, Mar 3, 2009.

  1. Vazza macrumors regular

    Joined:
    Nov 25, 2006
    Location:
    London, UK
    #1
    Just received an iPhone 3G from O2 on contract but am having problems connecting to the internet unless its connected to wifi. I have a strong O2 signal (5 bars) but am yet to see the 3G, EDGE or GPRS symbol next to it...I've checked on the O2 site for coverage and according to their map I should have HSDPA service.

    Under Cellular Data Network I have the following settings:

    APN: mobile.o2.co.uk
    Username: vertigo
    Password: password

    I've tried toggling 3G off and then on, I've also reset network settings with no change.

    Any help would be appreciated!
     
  2. iamwadey macrumors newbie

    Joined:
    Jan 3, 2009
    #2
    Soloution

    Hey mate if you are pay as you go simple change the mobile to payandgo.o2.co.uk

    Hope this helps.
     
  3. Vazza thread starter macrumors regular

    Joined:
    Nov 25, 2006
    Location:
    London, UK
    #3
    It's on an iPhone pay monthly tariff, so I don't think the cellular network settings are the problem. Also, forgot to add that I've reset the phone a number of times since yesterday but still no 3G/EDGE/GPRS :(...think I may have to call O2 again (5th time since I got the iPhone yesterday) to see if they need to change anything on their end :mad:
     
  4. ramases macrumors member

    Joined:
    Jan 14, 2008
    #4
    This may sound daft, but have you turned off Data Roaming under Network? When I first got mine I couldn't get access over 3g until I turned it off.
     
  5. Vazza thread starter macrumors regular

    Joined:
    Nov 25, 2006
    Location:
    London, UK
    #5
    ramases, Data Roaming is off (I believe O2 set this as the default).
     

Share This Page