Can't Connect To Internet Using Ethernet Cable!!!!!! help please!

Discussion in 'MacBook Pro' started by jt1992, Oct 12, 2010.

  1. jt1992 macrumors newbie

    Joined:
    Oct 12, 2010
    #1
    Hey all,

    I'm here at university and the wifi here sucks! it is so slow, it is working.However there is an ethernet port and I did connect to it this morning. But, this evening I tried connecting again and it wouldnt let me!

    At my university they require you to put in your student ID and pw in order for you to use the internet for both wi-fi and ethernet. But when i tried this evening it dint ask for my student ID or password.

    I went to settings and it did say that there was a connection and that "Ethernet has a self-assigned IP address and will not be able to connect to the Internet"

    i dont understand how come now it isnt working.
    I aksed my classmate nextdoor if his internet port was working through the ethernet port he said it was....

    someone help please! i am not that tech savy so keep vocabulary to something simple lmaooo.

    thanks!!!
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    You need to tell your Mac to use DHCP instead of self-assigned IP address.
     
  3. jt1992 thread starter macrumors newbie

    Joined:
    Oct 12, 2010
    #3
    It is set to use DHCP
    as it does say "Using DHCP"

    the status says : Ethernet has a self-assigned IP address and will not be able to connect to the Internet.

    and i am using DHCP.

    any clues in what to do?!?!:confused:
     
  4. Cave Man macrumors 604

    Cave Man

    #4
    This is a notorious problem with OS X. Sometimes deleting that connection (using the '-' in the Network pane) and then adding a new one ('+') can reset the DHCP address. You should give that a try.
     
  5. bchamorro macrumors regular

    Joined:
    Dec 31, 2007

Share This Page