Can't Connect to Mac OS 10.5.5 from Windows XP Pro

Discussion in 'MacBook Pro' started by darthpenguin, Dec 16, 2008.

  1. darthpenguin macrumors newbie

    darthpenguin

    Joined:
    Nov 5, 2008
    Location:
    Ontario, Canada
    #1
    I have a MacBook runing OS 10.5.5 and a Windows XP Pro Desktop. I have set up file sharing on both machines. The account username and password on the Mac is not the same as the account on Windows XP because the Windows machine is my dad's. I can connect to shared files on Windows from Mac by typing my dad's username and password when prompted. Only that UN/PW has access to the file shares for security reasons. But I cannot connect to my Mac from Windows XP because I am not prompted for a UN/PW. I get no error message, all I see is "Printers and Faxes" because my shared "Home" folder is set for; I have "Read & Write" permissions but "Everyone" has "No Access".
    Why do I not get a password prompt when connecting to the Mac? How do I get one?

    Thanks.

    Note: The mac is sharing files because if I give "Everyone" "Read & Write" permissions on my "Home" folder I can connect. but I still get no password prompt. Also attempts to connect to shared files on my brother's ibook G4 running OS Tiger from Windows will prompt for a password. If my brother enters his UN/PW all is well. So I think this is a Leopard Issue.
     
  2. darthpenguin thread starter macrumors newbie

    darthpenguin

    Joined:
    Nov 5, 2008
    Location:
    Ontario, Canada
    #2
    Update

    Update:

    I have Windows XP Pro running as a virtual machine through VMware Fusion on the MacBook. My account's username and password is identical to leopard's. I can connect to leopard's shares from that account. But when I set up a dummy account on the virtual windows (username: user1 password: password) I get the same behavior as I get with my dad's machine. Nether account ever prompt for UN/PW.
     
  3. darthpenguin thread starter macrumors newbie

    darthpenguin

    Joined:
    Nov 5, 2008
    Location:
    Ontario, Canada
    #3
    Solved

    Solved.

    OK. So I solved the problem. I will post the solution here for anyone who may stumble upon this post and have a similar problem. Simply open 'System Preferences' choose 'Accounts' choose 'Guest Account' and make sure that 'Allow guests to connect to shared folders' is unchecked. It seems an odd place for that option to be. It should be located in the 'sharing' preferences.
     

Share This Page