Can't connect to network/internet with my Linksys router

Discussion in 'Mac Basics and Help' started by Sundance2007, Jul 6, 2011.

  1. Sundance2007 macrumors regular

    Joined:
    Dec 20, 2007
    #1
    I can't seem to get my Mac to connect to the network or the net with my Linksys WRT610N router. I have Windows PC's as well as a Linux NAS server and printers that are connecting just fine. Linksys support was no help at all.

    I see the router OK but when I put in the WEP key (same one used on everything else) the connection fails, it will not connect.

    Any advice or idea why everything but my Mac's works just fine?

    Thanks
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #2
    Does the router have MAC address filtering enabled?
    If so, you will either need to add the your Mac's MAC address to the table, or disable the filter.
     
  3. Sundance2007, Jul 7, 2011
    Last edited: Jul 7, 2011

    Sundance2007 thread starter macrumors regular

    Joined:
    Dec 20, 2007
    #3
    UPDATE...........Got it all figured out and the mac's are on the network. Thanks for your help.

    Yes it is enabled and I see a list of all the computers and devices but I see nothing that allows me to add anything. There is a wireless client list button and when I click on it, it opens a window showing all the clients (see screen shot). There is a add button but when I click it it seems to add what is on the list but gives no option, no new window, nothing to add anything else.

    How do I add mac addresses?

    Or... is it a matter of the router scanning for local devices and their mac address within range? If that is the case it does not see my mac's.
     

    Attached Files:

  4. Sundance2007 thread starter macrumors regular

    Joined:
    Dec 20, 2007
    #4
    P.s.

    What is the newest FW version, this router has 2.00.00 B05.
     
  5. mogwat macrumors newbie

    Joined:
    Jul 7, 2011
    #5
    Router

    1) Look up the latest firmware for your router
    2) Back up your router configuration
    3) Make sure you have a) your ISP details b) relevant ip addresses of DNS servers and devices on your network.
    4) (optional - but recommended) Update firmware on router
    5) Turn off all Mac Address filtering, all security, all passwords on the router.
    6) Make sure the mac and your pcs can connect.
    7) Turn on one level of security (WPA/WEP, Mac address filtering,whatever)
    8) Make sure you can get everything to connect
    9) Add another level of security and repeat 8

    10) realise your router doesn't support WPA2 and that was your problem :)

    Good luck
     
  6. Sundance2007 thread starter macrumors regular

    Joined:
    Dec 20, 2007
    #6
    I think it does support WPA2. what is the advantage of WPA2 over WEP?
     

    Attached Files:

    • sec.jpg
      sec.jpg
      File size:
      28 KB
      Views:
      46
  7. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #7
    I've had so many problems relating to my WRT600n router that it got pitched after 4 months of problem after problem.

    An old WRT54G and DD-WRT firmware - has been the most reliable router I've had in 7 years now. Actually got the WRT600n because the WRT54G started crashing every week after 2 years of ownership. Couldn't reset it or anything to get it stable. After getting DD-WRT on it - it's been very stable, and after the headaches with my N router, (and lack of DD-WRT for my particular model) I went back to the stone ages.

    No regrets. :)

    Edit - not entirely sure about the advantages precisely - however 128 WEP isn't nearly as secure as I thought, after a friend of mine hacked into my router in 60 seconds using some free program he found. Used his video card to decrypt a few packets, rendered the key, cloned my MAC address, which I would have called BS on, had he not performed this in front of me.

    After that, disabled my radio, yanked the antennas, and ran cat5E to the everything else in my home...
     

Share This Page