Can't connect to school's WiFi

Discussion in 'macOS' started by Canerican, Sep 1, 2009.

  1. Canerican macrumors regular

    Joined:
    Jul 22, 2006
    #1
    I am writing this from a Panera Bread, as my school's internet won't work on my MacBook since a fresh install of SL.

    There isn't much to say, except I cleared out all my old Airport profiles, and my old networks. My school will let me connect for about 5 minutes, then it kicks me off (I see the exclamation point over the Airport icon in the menubar). I checked a friends MB without SL, and she is connecting no problem.

    My school's network was never protected according to Airport (never saw the padlock), but whenever I would go to connect it would ask for my username and password.

    I hope someone can help me - at least point me in the right direction, or else I have to downgrade, and I love QT X :cool:
     
  2. wedi42 macrumors newbie

    Joined:
    Feb 17, 2009
    #2
    do you use open dns by chance?
    i noticed the same thing today at my school.
    i was able to connect to the wifi from my cell phone, but not my laptop.
    it took me awhile, then i decided to delete the open dns ip addresses from network preferences and it worked instantly.
    not sure what changed, i think it has something to do with the 10.6 upgrade.
     
  3. pseudo7 macrumors newbie

    Joined:
    Oct 28, 2007
    #3
    I've had major wifi problems similar to this as well.

    Looking at the Apple forums, it seems that SL has weird and hard to narrow down wifi bugs that only affect a small percentage of users.
     
  4. Canerican thread starter macrumors regular

    Joined:
    Jul 22, 2006
    #4
    Ahh, I do use Open DNS. I never thought about it, but my DNS servers are grayed out, I can't erase them :confused:
     
  5. markojug macrumors regular

    Joined:
    Mar 16, 2009
    Location:
    In A House, Ontario, Canada
    #5
    Have you clicked that little Lock on the bottom left hand side of the window?
     
  6. Canerican thread starter macrumors regular

    Joined:
    Jul 22, 2006
    #6
    Yeah, it's unlocked.

    Here's what I see BTW. I cannot click on either of the IPs.
     

    Attached Files:

  7. Canerican thread starter macrumors regular

    Joined:
    Jul 22, 2006
    #7
    If anyone cares, I simply deleted my two preference folders, and it was problem solved.

    Simply reverting all your Network preferences back manually, and deleting your old profiles and networks does not work.
     

Share This Page