can't connect to WiFi

Discussion in 'iPod touch' started by Bob Coxner, Jan 27, 2012.

  1. Bob Coxner, Jan 27, 2012
    Last edited: Jan 27, 2012

    Bob Coxner macrumors 6502a

    Joined:
    Mar 24, 2011
    #1
    This problem just started today, after more than two years of working fine. I was having intermittent dropouts of my internet connection, so I reset my WRT54GL router back to factory defaults before setting up my router preferences again. Now my Touch can't connect.

    My Macbook Air connected wireless, after I entered my WPA2 password. My wired connections all work fine.

    I did have a major problem getting my iPad to connect again but that was finally solved by turning Airplane Mode off/on and then connecting to the network.

    On my Touch I turn WiFi off and back on. It shows the SSID of my network and the proper lock icon for WPA. But, when I click on that network it just shows blank entries for IP Address, Subnet Mask, Router, etc. I also get blank entries when I choose BootP and Static. I can connect when I turn WPA2 off but that's obviously not acceptable.

    I've restarted the router several times.
    I've turned WiFi off and on several times on the Touch. Same for Airplane Mode.
    I've restarted the Touch (slide to "power off")
    I reset the network settings via Settings > General > Reset > Reset Network Settings.

    None of these worked. My suspicion was the router but I have no problem connecting wireless with my Macbook Air and iPad.

    The only thing I haven't tried is a hard reboot of the Touch (Sleep/Wake plus Home) I assume this puts everything back to factory defaults and I'd rather avoid that.

    Any suggestions? The problem clearly lies in trying to get to a password box for the WPA2 but I never get that option. How can I get to the WPA2 password dialog?

    ================

    Edit: Solved. I tried to launch Safari. It told me I wasn't connected and then gave me the password dialog box. Everything is back to normal.

    Perhaps this will help someone else.
     
  2. tunerX Suspended

    tunerX

    Joined:
    Nov 5, 2009
    #2
    I just had this problem with my sons device.

    I ended up doing a restore and it has worked fine since.
     

Share This Page