Can't connect to WiFi

Discussion in 'iMac' started by kingcrowing, Feb 2, 2012.

  1. kingcrowing macrumors 6502a

    kingcrowing

    Joined:
    May 24, 2004
    Location:
    Burlington, VT
    #1
    So I've got an odd problem, here's the scenario:

    27" iMac 2.8GHz Quad Core running OS X 10.7.1, and a netgear router (connected to a Comcast modem).

    It sees the network, connects then drops the network. However, a MacBook Air running 10.6.8, an iPad, and a Sony Viao running Windows 7 can connect and stay connected to the network fine.

    This made me think that something with the iMac's WiFi card is broken so we brought it to work and connected it to our network (802.11x, WPA2 Enterprise, Cisco routers) and it worked perfectly. He brought it back home, still couldn't connect to his network.

    We brought it to the campus Apple store and they replaced the airport card and it seemed to resolve the problem for a bit, but now the issue has come back.

    Yesterday we did a full time machine back up, wiped the hard drive and did a full OS X Lion re-install and restored from the Time Machine back up, ran all of the Apple software updates and it connected to the WiFi here at work fine.

    Brought it home, still won't connect to his network. This would make me think that it's an issue with his home network but all the other devices are working fine.

    We had a Comcast technician look at the network and they found nothing wrong.

    Thoughts? Suggestions? Help!
     
  2. leman macrumors 604

    Joined:
    Oct 14, 2008
    #2
    Yes, it seems that the Lion WiFi drivers for some 2011 iMac models are buggy. This has long been discussed and documented and many people are affected (my home iMac as well). One solution that helped soem people was to downgrade the drivers to ones from Snow Leopard, but that has its own share of problems. Try installing the latest Lion update, today's 10.7.3 has some references to the WiFi stability, maybe they finally fixed it. I can't try it yet as I am at work.
     
  3. leefisher macrumors newbie

    Joined:
    Nov 3, 2010
    #3
    Perform a Software Update, as the most recent update should fix it. This has been a problem across all Mac products with Lion, but so far it seems to have worked ok on my 2009 MacBook Pro
     

Share This Page