Can't connect to wifi

Discussion in 'MacBook Pro' started by throttle, Mar 10, 2013.

  1. throttle macrumors newbie

    Joined:
    Mar 10, 2013
    #1
    Hey everyone,
    I haven't been able to connect to my wifi since starting up this morning. I found a bunch of other threads about this but couldn't find anything that worked with my problem, so here are the details.

    I'm able to connect to the ethernet without a problem, and I am able to connect to the wifi from my iphone and ipad. I have also tried restarting the router and modem a few times and changing settings with the security in the router but still was not able to connect from my laptop. (the other devices were able to connect each time with no problem so I'm pretty sure it's not the router)

    When trying to connect normally through the wifi icon in the menu bar, it tells me "Connection timeout"

    When going through system preferences-->network-->assist me, it tells me "The password you entered is invalid." (I've checked it many times, and even tried changing the router password and wifi name thinking another router may be confusing it, no luck, and the password is not incorrect)

    When going through the diagnostic, it lets me select the network and enter a password but then tells me, "This computer was unable to join the AirPort Network you selected. You may have entered an incorrect password or network name, chosen the wrong type of wireless security, or you may be out of range of the base station." (again, the password was not entered incorrectly, and I am within a couple of feet of the router and it worked just fine last night)

    From what I've read online, if the wifi card was bad it wouldn't even show the available network names or be able to turn the card on in the first place. I've tried restarting my computer, resetting pram, and rebooting to the Windows 7 bootcamp which is also unable to connect.

    I'm running OSX 10.6.8 and it's an '07 macbook pro. Under system profiler, the airport card shows
    Software Versions:
    Menu Extra: 6.2.2 (622.2)
    configd plug-in: 6.2.5 (625.6)
    System Profiler: 6.0.1 (601.1)
    Network Preference: 6.2.2 (622.2)
    AirPort Utility: 5.6.1 (561.3)
    IO80211 Family: 3.2 (320.1)
    Interfaces:
    en1:
    Card Type: AirPort Extreme (0x168C, 0x87)
    Firmware Version: Atheros 5416: 2.1.14.6
    Locale: FCC
    Country Code: US
    Supported PHY Modes: 802.11 a/b/g/n
    Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 149, 153, 157, 161, 165
    Status: Not Associated​

    I've provided as much info as I can think to give, any help would be greatly appreciated. Thanks!
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
  3. throttle thread starter macrumors newbie

    Joined:
    Mar 10, 2013
    #3
    It's a Netgear N150 WNR1000v3
    Firmware: V1.0.2.54_60.0.82NA (updated today)
     

Share This Page