can't connect to windows 7 shared drive using smb: invalid username or password error

Discussion in 'MacBook Air' started by candybars, Feb 3, 2011.

  1. candybars macrumors newbie

    Jan 2, 2011
    I am hoping someone here would be able to help me solve this :

    I have the new 13" Macbook air running Snow Lepard.

    I am trying to connect to a desktop on my home network running windows 7 using SMB but am getting an invalid username or password error and it is not working. It did work for a while but all of the sudden stopped and I did not change any of the settings on the windows machine.

    More in detail: I go to finder, choose 'go'->'connect to server', I enter 'smb://mypcname-PC'. It then seems to connect and asks me for a username and password. I enter that information and get a message 'you entered an invalid username or password'. I also tried using guest account but for some reason it is telling me that server does not allow guest access.

    Just one more comment - when I initially set this up, I had the same problem but then my windows PC did not have a password and would just connect automatically when I booted up that machine. After I edited the user information on the windows 7 machine and added a password it 'fixed' the problem also on the mac and I was then able to use that same username and password to connect remotely using SMB. I could see my shared drives and everything... At some point all of the sudden it stopped working.

    I really hope someone there can help me with this. Thanks in advance!!!
  2. candybars thread starter macrumors newbie

    Jan 2, 2011
    Thanks. I was somehow able to get it to work even with the non guest registered user by changing the password on my account on the windows 7 (have no idea how it worked). However, related or not I now have a serious network speed issue - my internet speed has dropped to about 20% of what it is supposed to be and is on other computers on the same network (speed tests, files, even moving files from the windows computer to the mac...) in a very 'choppy' manner. It has happened to me before and they replaced the airport chip in the macbook air but that did not help and I have that going on again. I may post another question on this subject as I that is a far bigger issue for me right now. Thank you in any case..

Share This Page