Can't connect to Windows as anything other than "Guest"???

Discussion in 'macOS' started by alw4416, Feb 12, 2008.

  1. alw4416 macrumors member

    Joined:
    Jul 10, 2006
    Location:
    Kansas City
    #1
    When trying to connect to a Windows XP machine from 10.5.2 I am unable to connect as anything other than "Guest". I have searched everywhere for the answer and it appears a lot of people have this same issue but I thought it was to be resolved as of 10.5.2 I used to be able to connect as a user to a Windows machine using username and password in Tiger, but this seems to have got broken in Leopard, as has many other things. The really bizarre thing is, it always connects to the Windows machine as a "Guest" regardless of what name and password entered. Why then even have the option to "Connect As"???
     
  2. iCeFuSiOn macrumors 6502a

    Joined:
    Jul 18, 2007
    #2
    That's strange, I'm able to authenticate as a user on a Windows-based PC without an issue when I am connecting to Windows (SMB/Samba) shares, I'm running 10.5.2 on my notebook and Windows XP SP2 and Windows Server 2003 SP2 on both computers that I connect to.
     
  3. spanieldecks macrumors newbie

    Joined:
    Feb 18, 2008
    #3
    Perhaps an answer?

    Hi there, I recently joined the annoying 'mac are better than pcs' crowd with a macbook pro a couple of months ago (it was Vista that finally made me jump across). I don't think I'll be looking back!

    Anyway, I had the same issue precisely. I think what is happening is that the mac is logging on a guest since no greater credentials are (apparently) required. The problem is actually (surprise surprise) at the PC end! What you need to do is to turn off 'simple file sharing'. Do this by right clicking my computer, then go to folder options, then at the bottom of one of the lists is 'simple file sharing'.

    When this is turned off, right click on one of your shares and edit the users and permissions. You will find that the default user is 'Everyone'. remove this and add your own user as the only person allowed to access the resource, and enable full permissions for you. I.e. a guest account will now be refused access.

    Go back to Leopard, and you will find that when you renegotiate the connection, you will be 'logged in as' yourself, and you will have full access!

    I hope this helps?

    Cheers,
     
  4. iCeFuSiOn macrumors 6502a

    Joined:
    Jul 18, 2007
    #4
    Just to add, ensure that your user name and password on the Windows machine matches your credentials on the Mac so that when it handshakes it provides the correct information to the Windows PC (or you may need to use "Connect As" every time you connect to a Windows share.)
     

Share This Page