Can't connect to Wireles LAN (dlink DIR-625)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chuckd62687, Jul 18, 2007.

  1. chuckd62687 macrumors member

    Joined:
    Mar 15, 2007
    #1
    Is there anyone out there who has a dlink DIR-625 that can connect their iPhone to it with WPA or WPA2 encryption enabled? I can only connect to it with encryption turned off.
     
  2. Resevdog macrumors regular

    Joined:
    Jul 5, 2007
    #2
    Draft n

    Being a draft N router, that model is not supported by the iphone or more to the point, the iphone doesn't work on draft n. There may be a work around. In your router configuration (through the browser interface), trying setting your antenna to broadcast in g only. Should be under a tab labled SETUP->Wireless Settings...I suspect your broadcasting in N. If that doesn't work, then you may be s.o.l.

    On the other hand, if you can connect with encryption off, my next feeling is one of your router based encryption settings is set wrong. Go into those and make sure that you are using the correct key length/type/standard, etc. I'm nearly positive your issue is router settings based.
     
  3. NemoMac macrumors member

    Joined:
    Jul 10, 2007
    #3
    I have a D-Link brand .11g router at my folks' house that I can't get to work for my iPhone unless I turn the encryption off. I have tried a lot of settings too... I think it might be the brand.

    Ironically, at my place the iPhone works wonderfully with the cheapest router I could find on TigerDirect - by a company called "TrendNet."

    Go figure.
     
  4. Resevdog macrumors regular

    Joined:
    Jul 5, 2007
    #4
    somethings not right...

    Are you absolutely sure your encryptions match? Meaning, the router is using WPA and your iPhone setting for wifi is set to wpa? Is it possible your home router is using WEP? If so, are you set to Passphrase or AScii/hex?

    I believe based on your posts you have this set properly and understand the difference, but I had to check.

    have you tried to start fresh? Meaning, powering down the router, deleting ("forgetting") all wifi connections you've attepted to set up? As a last resort, have you tried to restore the iphone? Is your router firmware up to date? I checked the dlink website and there are a number of revisions for your router.

    I dont think its the brand as I have a dlink and it works perfectly.
     
  5. bdj21ya macrumors 6502a

    bdj21ya

    Joined:
    Sep 13, 2006
    #5
    I have a lot of problems connecting to the d-link router at my brother's house too. It connects, but then the traffic doesn't go through
     

Share This Page