Can't connect to wireless network

Discussion in 'macOS' started by Thomas Harte, Dec 25, 2006.

  1. Thomas Harte macrumors 6502

    Nov 30, 2005

    I'm at a parent's house for a week or two and I'm having difficulty getting my Core Duo MacBook Pro to connect to the wireless network here. This, Windows, computer seems to have no problem.

    The network is a WPA-PSK/TKIP type and the MacBook Pro detects the network and correctly identifies it as "WPA Personal". But when I enter the network's personal key, all I get is an error saying that a connection could not be made. The console doesn't seem to contain any further useful information.

    From the Windows PC I can access the web interface to the wireless router and I have verified the personal key by resetting it (to the same thing) there. That didn't seem to help. I've also tried entering the key in quotes to the MacBook Pro. Beyond that I really have no ideas.

    Anybody got any suggestions?
  2. Compile 'em all macrumors 601

    Compile 'em all

    Apr 6, 2005
    Make sure that you don't have caps lock on. As well, use the checkbox that lets you see what you are typing in instead of *.
  3. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    What kind of router are you using? With WEP, there are all kinds of troubles associated with hashcoding passwords when they are not exactly the right length. However, my impression was that with WPA, this is not an issue.

    This is an alphanumeric key, right? E.g. you are not trying to enter the hex converted key?

    Are you sure you're entering the right key? Did you verify that re-adding the same network with the same key on the Windows computer works, or do you just mean that the computer was already connected and so you know the network is working?
  4. tominated macrumors 68000


    Jul 7, 2006
    Queensland, Australia
    i had that problem once (with an unsecured network tho). try connecting right near the router and see if that helps. if it does it's your airport signal
  5. Thomas Harte thread starter macrumors 6502

    Nov 30, 2005
    I've confirmed the 8 letter alphanumeric WPA key by both resetting it on the router and re-entering it onto the working Windows PC. I've tried it several times on the MacBook Pro, some with the password visible and none has worked. The only oddity I got from the Windows PC is that when I disconnect from that network and then reconnect it tells me I have the wrong password. Entering the same one again fixes that problem. This is an old D-Link 802.11b router which I think only supported WEP initially. Is it possible that the WPA implementation may be flawed in some way and the Windows PC is just more fault tolerant than the Mac? It seems to have its own manufacturer-specific software for managing the wireless network that has usurped Windows' own wireless network management.

    I have no idea what the hex converted key would be, but I note that the "OK" button (or equivalent) only becomes clickable when I enter the final letter so I think it gets what I mean. I also tried the quotes to make clear I was using an ASCII key and not a hex one based on a tip I found via Google.

    Trying the MacBook Pro in the same room as the router, about 3 metres away and with no significant obstructions makes no difference to the outcome.
  6. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    Are you sure you have an 802.11b router? Correct me if I'm wrong, but I believe that 802.11b + WPA is a very non-standard configuration. I don't think the formal requirements for WPA allow for an 802.11b router to do it. So I think your problem may be your router and OS X being strict about WPA requirements.
  7. Thomas Harte thread starter macrumors 6502

    Nov 30, 2005
    It's definitely 802.11b. It's a D-Link DI-614+, and the Windows PC reports the connection speed as 11 Mbps with "very strong" signal strength. A little 'net research reveals that the router also supports a non-standard D-Link specific 22 Mbps type of connection, so it seems to be quite original in its implementation of several things.

    If WPA isn't really meant to be supported on 802.11b that would explain what's going on. It's one thing to expect your computer to work easily with other equipment, quite another to expect it to work easily with technically broken equipment!
  8. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    I kept googling on that topic after I posted, and now I'm somewhat confused. They're definitely not the only ones... Apple supposedly upgraded their original airport cards to be able to connect to (at 802.11b) WPA networks. I'm just not sure.

    This person claims to have made a WPA connection using a powerbook:

    This person claims that 802.11g cards have trouble acquiring connections on this router (although I'm presuming one/all of your Windows computers also have 802.11g adapters).

    Some people have also specifically complained about all kinds of problems with the wireless in Intel macs, although the experiences seem to be based on some hidden variable related to setup, as not everyone complains about this.

    Any chance you can back down to WEP or no security and make sure that doesn't work?

    And dumbest question, but you don't have MAC filtering enabled, do you? And if you do, this computer is on the list with the correct MAC address, yes?
  9. peterguy macrumors newbie

    Dec 31, 2006
    I'm also visiting my parents', who also have a DI-614+, and my shiny new MBP can't connect to it if it's using WEP

    or WPA.

    I have not yet gotten the MBP to connect to the DI-614+ when using authentication. In case it will help someone

    else, here are the steps I've taken (none of which have had any effect):

    - make sure passphrase is correct (duh): home tab, wireless button, view source, find <input type="password"

    name="wpapsk1" size="40" maxlength="64" value="[this is the passphrase]">

    - change channel from "auto scan" to a specific channel

    - disable "turbo" mode: Advanced tab, Performance button, 4X mode disabled

    - change rates (same screen as for 4X) to 1-2-5.5-11

    - change preamble from short to long

    - upgrade firmware from 3.43 (jul 19, 2004) to 3.44 (nov 16, 2005)

    Throughout the process, I noticed that the log file (status tab, log button) contained entries for the

    MBPconnecting and authenticating:
    Dec/31/2006 22:26:16 DHCP lease IP to 00-19-E3-05-A7-B7
    Dec/31/2006 22:26:12 Authentication success 00-19-E3-05-A7-B7
    Dec/31/2006 22:26:12 Wireless PC connected 00-19-E3-05-A7-B7

    Also, the DHCP page (home tab, DHCP button) had an entry for the lease:
    Host Name IP Address MAC Address Expired Time 00-19-E3-05-A7-B7 Jan/07/2007 22:27:16
    (possibly significantly, there is no host name for the entry, even after I specify a client id in the MBP network


    Looks like the media layer is connecting, but there is no level 4 connectivity.

    I also made network configuration changes to the MBP, such as changing from DHCP to manual addressing.

    None of the above changes had any effect.

    I'll post more if/when I come up with a solution (other than "replace the DI-614+").

  10. chrismargaret macrumors newbie

    Mar 2, 2011
    can't find wireless networks

    I have an older Ibook G4 and recently is has developed a problem when waking from sleep, it no longer connects to my airport base station. I search for networks and it is hit an miss if it lists some or none of the available signals in my area. Any ideas why my G4 has begun to be unreliable with the wifi connections. I am sitting 3 feet from my airport extreem base station so the signal is max.

Share This Page