can't connect to wireless since upgrading to Lion

Discussion in 'Mac Basics and Help' started by staypuffinpc, Jul 21, 2011.

  1. staypuffinpc, Jul 21, 2011
    Last edited: Jul 21, 2011

    staypuffinpc macrumors member

    Joined:
    Jun 4, 2008
    #1
    I upgraded a late 2006 MB with 4 GB of 667 MHz DDR2 SDRAM and a 2 GHz Intel Core 2 Duo processor to Lion. Now, it can't connect to wireless. I see my local network, but I get the message, "Unable to join Wi-Fi network." The system has given me a self-assigned IP. I've tried to renew my DHCP lease manually, entering the WAN IP of the router as well as the subnet (I have another computer that I haven't yet upgraded that I was able to use to get this info). Still, no luck.

    Any ideas on how to resolve this?

    EDIT: Looking at my the MAC addresses in the wireless statistics of my router reveals that my MB is connected with about a 70% signal strength. However, it's the only of 5 current connections that does not show up in the DHCP client list. I changed the name of the computer when I reinstalled. I wonder if that's also causing an issue.
     
  2. staypuffinpc thread starter macrumors member

    Joined:
    Jun 4, 2008
    #2
    got it!

    OK, I tried a lot of things, including zapping the PRAM, turning things on and off, etc., but none worked. Finally, I renamed the plist file found at /Library/Preferences/SystemConfiguation/preferences.plist to "preferences.plist.old." It took a minute, but then the connection finally went through.
     
  3. staypuffinpc thread starter macrumors member

    Joined:
    Jun 4, 2008
    #3
    Not really fixed

    Ok, so after using this for about a week, it's getting REALLY annoying. I have been able to connect to the wireless, but only after entering the password EVERY TIME. If I try and tell the network to remember the password, I get an error and it tells me that I can't connect (even though I do). Today, I totally lost any connection ability and I had to trash the plist file again. I'm not sure what's going on, but going through online records, it seems that this problem crops up every time someone upgrades their system--since Tiger!

    Has anyone else encountered this issue? How do you fix it permanently?
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada

Share This Page