Can't connect to WPA-locked router

Discussion in 'Mac OS X Server, Xserve, and Networking' started by CrazyChihuahua, Aug 1, 2008.

  1. CrazyChihuahua macrumors newbie

    Mar 1, 2008
    Hey folks. We recently tried to put a WPA key on our router to lock it out, but for some reason my Mac could not connect to the network. It always worked fine otherwise, and the Windows PC connected fine, but mine did not work. I am sure it was not a case if incorrect password input as it was inputed many times, each with no success.

    When switching to Windows on the Mac (with Bootcamp) it seemed to work fine. I didn't get much time to test it though because the router was unlocked and reset soon after.

    Any reason why it would suddenly stop working, and is there anything else that would have to be done in the router settings to let the Mac connect?

    Thanks for any help you can give.
  2. Eraserhead macrumors G4


    Nov 3, 2005
    Macs should work fine with WPA, though did you set a password (TKIP) or did you try and generate the password automatically (AES)?

    I believe the Mac only works with an explicitly set password.

    PS You should have a password on your router.
  3. CrazyChihuahua thread starter macrumors newbie

    Mar 1, 2008
    The password was set, and not generated automatically. I figured it'd work fine with WPA, as it's just a password entry. It worked fine at a different place with a different router before. Perhaps something was screwed up when setting up the password, and we just ahve to try again.

  4. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    It's much more odd to have this problem with WPA than with WEP... but it does happen.


    1) What kind of router is it? And is this an 802.11n network or an 802.11g network?

    2) Is it WPA or WPA2?

    3) How long is your password? If it's very short or very long, try making it more moderate in length -- 8 alphanumeric characters is pretty good. A strong 8 character password is not particularly easy to crack. The reason for this is it's possible that there's some incompatibility in the way hashing is done -- for instance, if you specify a very short passphrase, it may not have enough information in it to uniquely specify one hex key, and if the computer and the router hash (fill in the extra spaces) differently, the result may be a refusal to connect.

Share This Page