Can't connect to WPA2 Enterprise-based access points

Discussion in 'macOS' started by Cubytus, Dec 19, 2010.

  1. Cubytus macrumors 65816

    Joined:
    Mar 2, 2007
    #1
    Hi everyone,

    *_Configuration_*: MacBook Pro 7,1, 2,4GHz, Mac OS X 10.6.5.
    Three user accounts (one for me, two for friend's backup), two of them have admin rights. I'm using one of these accounts.

    I'm having a strange issue with *WPA2 Enterprise*-based access points, namely, the private one on my university's campus, and the eduroam one. Eduroam is, roughly, a SSID that is available in participating institutions worldwide, and allows connection from personnel registered in any of these institutions without having to ask for a guest access.

    On eduroam, one is supposed to select the eduroam SSID in the list of network available, select "Security: WPA2 Enterprise", and type his institutional email address as a username. "Password" should remain blank for now, and in front of the "802.1X", select "Auto". On clicking the "Connect" button for the first time, a "Check certificate" dialog should appear with three buttons, "Display", "Cancel", "Continue", where one would click "Continue". Finally, a "802.1X authentication" dialog would appear, when a user would put his email address as username, and type in his institutional password to log in. Then, the user would be online without further fuss.

    On my university network, it's even simpler. One should select it, type in the IT login, then the corresponding password, before being allowed to be online.

    On my normal user account, I never get the "Check certificate" dialog for eduroam, an on the uni's network, it never seems to connect. Ultimately, I get the exclamation point over the wireless waves, meaning that the card self-assigned an IP. Then it tries to connect again (the icon is waving), then fails again. No other authentication is affected, and a quick look in the logs doesn't show anything salient.

    On the other user account, the connection to either of these SSID works as written, on the first try.

    So it's no hardware issue.

    I first tried to create a new wireless profile, and recreate the connection. It failed, once again, for both networks.
    So to the Genius Bar I went. Since it's a login issue, we deleted the *~/Library/Keychans/login.keychain* item, rebooted. Since the issue couldn't be reproduced in store, he advised me to delete the "session" keychain and reboot if the problem persisted. He asked me if the computer crashed while I was logged in anywhere in the past (before 10.6.5), and yes I said, adding that I let AppleJack do the automated repair. He checked with a colleague, on a tech forum, spent 30 min with me, but came back with the dreaded conclusion that, at least in that store, they ended up doing what he named "partial restore" to correct a similar issue, in contrast to "archive and install".

    Off to the uni I went, and recreating the connection failed again. In the Access Keychain, I then removed the session keychain, with *both* the references and files (default is reference only), since they referred to passwords I already knew, rebooted, logged in, and tried to connect, to no avail. The other user account still works.

    What else should I try? Ironically enough, I reinstalled OS X more times in two years than I did Windows in eight, and want to avoid the time-consuming step of reinstalling applications, and the very tricky part - ownership issues - of manually importing documents and only selected settings.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    You WHAT? Didn't you ever hear of "archive and install?" I've archive and installed OS X a handful of times and always came back at the end with the same finder windows I had open before the install and NEVER had to reinstall any OS X apps. Ever.

    As for wifi working seamlessly with OS X and the network you are trying to use, perhaps the support people for your network can tell you if there is anything you are missing, ie radius server or whatever.

    But please don't complain about having to reinstall OS X along with all your apps. That is almost always unnecessary. Normally there is no reason to ever do that. Even moving from one Mac to the next is a simple matter of finding a firewire or usb cable to transfer everything. I have done a complete wipe install after our daughter hacked the admin account on her Mac Mini to enable iChat in the middle of the night and she had things so badly munged I wiped and reinstalled her OS from scratch. That was to recover from hacking, not normal operation.

    When I'm trying to get the Apple Store geniuses to help me with a network related problem, I leave my Mac logged in at home with "back to my mac" enabled. We then use back to my mac from the Apple store so they can log in and see what I see as if they were in my house using my machine. BTMM is a mobile me thing which is normally a $99 annual subscription. Perhaps they offer an education discount. I'm not sure.
     
  3. Cubytus thread starter macrumors 65816

    Joined:
    Mar 2, 2007
    #3
    Hey, glad for your answer, but archiving and installing is sure to put the user profile back where it was, including faulty profile files. And since it only happens in my user account, the local IT people can't do anything. That's the reason why archive & install is not an option here, because of this bug.

    I followed their instructions to the line, both in my friend's account (he never used it yet), and mine. In his, worked on the first try. In mine, never could I get online.
     

Share This Page