Can't connect wifi on Yosemite DP 4

Discussion in 'OS X Yosemite (10.10)' started by mc666, Jul 22, 2014.

  1. mc666 macrumors newbie

    Joined:
    Jul 22, 2014
    #1
    Hi,

    After upgrading my 2007 mid iMac from DP 3 to DP4 I am not able to connect my wireless connection at all. It just keep showing "Scanning neowork...." I also couldn't see any wireless network list even though there are several wireless network around me.

    Any advice or others having the same issue on connecting wireless network?


    Thanks in advance.
     
  2. guatecham macrumors newbie

    Joined:
    Jul 22, 2014
    #2
    Same problem

    I have the same problem and I'm still looking for solution
     
  3. mindlessmissy macrumors newbie

    Joined:
    Apr 13, 2012
    #3
    Minor fix ...

    Ran into the same problem ...

    Luckily I had a backup of DP3 around, so I just swapped the IO80211Family.kext from that system into the Extensions folder of DP4 and rebooted. That worked ! Grab here if you don't have a personal backup available: https://www.sendspace.com/file/4v4a4r

    Don't know if this is going to be prevalent with further releases because that will not bode well for those of us who are currently experiencing this ...
    I don't like the idea of swapping old kexts into newer releases. I saw that the version number for the IO80211Family.kext changed slightly from DP3 to DP4 but I don't know what Apple did to cause this WIFI problem.

    Hopefully, it gets sorted ...
     
  4. Killa Aaron macrumors regular

    Killa Aaron

    Joined:
    Nov 14, 2011
    Location:
    Chicago
    #4
    I can't connect my Bluetooth keyboard since DP4 and I've tried everything, restarting the computer and putting the keyboard in discovery mode. I know it's not the keyboard cause im typing this right now on my iPad with it. I don't have a usb keyboard to connect to log in so now im stuck at the login screen, WTF Apple do you test anything anymore?:mad:
     
  5. stoney05, Jul 23, 2014
    Last edited: Jul 23, 2014

    stoney05 macrumors regular

    Joined:
    Sep 26, 2011
    #5
    I have this problem too.

    It eventually connected but took several minutes
     
  6. guatecham macrumors newbie

    Joined:
    Jul 22, 2014
    #6
    Thanks

    Thanks for your help I'll try later :D
     
  7. mc666 thread starter macrumors newbie

    Joined:
    Jul 22, 2014
    #7
    Thanks

    It didn't work for me. I managed to get wireless network lists by swapping the IO80211Family.kext but still not able to connect them.

    Thank you for your advice!
     
  8. guatecham macrumors newbie

    Joined:
    Jul 22, 2014
    #8
    It doesn't work

    I tried the solution described here but It don't work for me. I still having connection problems :confused:
     
  9. Sakellaris macrumors newbie

    Sakellaris

    Joined:
    Jul 24, 2014
    Location:
    Nea Makri Marathon Greece
    #9
    I confirm it works but it must be installed with kext utility

    btw tnx m8
     
  10. menano macrumors regular

    menano

    Joined:
    Jun 7, 2011
    Location:
    Neverland
    #10
    I just installed the public beta and I can't even turn the wifi on. I press turn on as many times as I want but with no effect..
     
  11. scottytwo macrumors member

    Joined:
    Sep 8, 2012
    #11
    really nervous about trying this blindly but really don't want to roll back, everything else runs pretty damn smooth for public beta!

    would this work for a 2008 iMac 8,1?
     
  12. littlblackangel macrumors newbie

    littlblackangel

    Joined:
    Nov 6, 2011
    Location:
    Toronto, Canada
    #12
    thank you so much for this! This solved my problem!:d

    ----------

    THANK YOU VERY MUCH FOR THIS! This solved my problem along with Mindlessmissy's post!:D
     
  13. flinnjamin macrumors newbie

    Joined:
    Jul 26, 2014
    #13
    It worked

    I downloaded the file mentioned above, then grabbed the Kext Utility tool from this site: http://www.insanelymac.com/forum/topic/140647-latest-kext-utility-mavericks-super-speed-edition/

    I started up the Kext Utility app and it did some things to repair file permissions in the Extensions folder first. Then I dragged the kext file I downloaded from my Downloads folder onto the Kext Utility and it backed up the existing kext file and installed the downloaded file into the right folder with permission. After that I rebooted and my wifi network showed up and it connected correctly.

    Thanks for the solutions, I was pretty bummed out after the beta install.
     
  14. jbeck22 macrumors newbie

    Joined:
    Nov 20, 2013
    #14
    After I installed the public beta, I had NO issues with network / internet connectivity...until tonight. Luckily I found this post on my iPhone and was able to try this solution and it really worked for me!

    Thanks OP for posting this. You saved me a bunch of time and headaches.

    Thank you again!
     
  15. Rumple, Jul 26, 2014
    Last edited: Jul 26, 2014

    Rumple macrumors member

    Joined:
    Jul 21, 2011
    #15
    Thanks a bunch it worked for me. It almost looked like the kext was exactly the same so I was worried it wouldn't work. Here I am posting now with Yosemite using wifi. Thanks!


    Public Beta- early 09 mac mini.



    I never used that program just winged it. :)
     
  16. floyd93 macrumors newbie

    Joined:
    Jul 28, 2014
    #16
    wifi finally

    thanx a lot, it worked for me too
     
  17. bluephoenix macrumors newbie

    Joined:
    Aug 4, 2014
    #17
    Wifi finally worked!!!!

    After 5 days and so much troubleshooting this Wifi Fix finally worked for me. THANK YOU SO MUCH!!!! :)


    I'm running 15'inch Early 2008 Mac OS Yosemite 10.10

    Here is what I did to get the WIFI working as described above.


    1. Download & Run Kext Utility
    - http://cvad-mac.narod.ru/files/Kext_Utility.app.v2.5.7.zip

    2. Download & Extract
    - IO80211Family.kext zip https://www.sendspace.com/file/4v4a4r

    3. Let Kext Utility do its job repairing permissions, system cache, etc.. then Drag & Drop the extracted IO80211Family.kext file into the Kext Utility

    4. Restart MAC OS X Yosemite 10.10.......BINGO!! WIFI working again! :)
     
  18. FrankseinMac macrumors newbie

    Joined:
    Aug 13, 2014
    #18
    Wifi Problem with the Public Beta

    Hi, I am using the Yosemite Public Beta on my iMac and have the same wifi problem. Can I use the same kext file to fix it?
     
  19. dannylloyd macrumors newbie

    Joined:
    Aug 12, 2014
    Location:
    Manchester, GB
    #19
    Try it inside system preferences ,that fixed it for me

    ----------

    If you mean the tutorial on this thread, I did and it worked well
     
  20. guatecham macrumors newbie

    Joined:
    Jul 22, 2014
    #20
    I can't fix the problem with the DP4 but when upgrade at the DP5 the problem was solved
     
  21. FrankseinMac macrumors newbie

    Joined:
    Aug 13, 2014
    #21

    Thanks for this info. Any idea if there will be an update for the public beta version in short time.
     
  22. guatecham macrumors newbie

    Joined:
    Jul 22, 2014
    #22
    Really I don't know the dates of new public releases, but at developers upgrades Apple are posting a new every 15 days. The next should be at August 18, but I don't kwow if there any public upgrade too
     
  23. rrm74001 macrumors regular

    rrm74001

    Joined:
    Nov 11, 2008
    #23
    This worked great on my 2008 15-inch MacBook Pro running Mac OS X Yosemite Public Beta 1.

    I used the iKext app (since it has official support for Yosemite) to install the new IO80211Family kext. After a reboot, Wi-Fi is working fine! Super easy. Basically drag and drop.
     
  24. matiastucci macrumors newbie

    Joined:
    Aug 23, 2014
    #24
    Still having problem


    I just did this, thinking it will work for me, but it didn`t. Any additional help??

    Thanks!
     
  25. anon1938210 macrumors newbie

    Joined:
    Sep 22, 2014
    #25
    I had the same problem but didn't want to mess with system files.
    I was able to resolve the problem from System Preferences by setting all adapters/services other than the Wi-Fi adapter as Inactive.
     

Share This Page